POJ 2151 Check the difficulty of problems 详细题解 (概率DP)

15 篇文章 2 订阅



Check the difficulty of problems
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 7351 Accepted: 3174

Description

Organizing a programming contest is not an easy job. To avoid making the problems too difficult, the organizer usually expect the contest result satisfy the following two terms: 
1. All of the teams solve at least one problem. 
2. The champion (One of those teams that solve the most problems) solves at least a certain number of problems. 

Now the organizer has studied out the contest problems, and through the result of preliminary contest, the organizer can estimate the probability that a certain team can successfully solve a certain problem. 

Given the number of contest problems M, the number of teams T, and the number of problems N that the organizer expect the champion solve at least. We also assume that team i solves problem j with the probability Pij (1 <= i <= T, 1<= j <= M). Well, can you calculate the probability that all of the teams solve at least one problem, and at the same time the champion team solves at least N problems? 

Input

The input consists of several test cases. The first line of each test case contains three integers M (0 < M <= 30), T (1 < T <= 1000) and N (0 < N <= M). Each of the following T lines contains M floating-point numbers in the range of [0,1]. In these T lines, the j-th number in the i-th line is just Pij. A test case of M = T = N = 0 indicates the end of input, and should not be processed.

Output

For each test case, please output the answer in a separate line. The result should be rounded to three digits after the decimal point.

Sample Input

2 2 2
0.9 0.9
1 0.9
0 0 0

Sample Output

0.972




题意:
ACM比赛中,共M道题,T个队,pij表示第i队解出第j题的概率
问 每队至少解出一题且冠军队至少解出N道题的概率。


解析:DP
设dp[i][j][k]表示第i个队在前j道题中解出k道的概率   (学会这种表示方法)
则:
dp[i][j][k]=dp[i][j-1][k-1]*p[i][j]+dp[i][j-1][k]*(1-p[i][j]); //这两种来源,第j到做出来/没做出来+前j-1到做k-1/k到题概率
先初始化算出dp[i][0][0]和dp[i][j][0];
设s[i][k]表示第i队做出的题小于等于k的概率
则s[i][k]=dp[i][M][0]+dp[i][M][1]+``````+dp[i][M][k];


则每个队至少做出一道题概率为P1=(1-s[1][0])*(1-s[2][0])*```(1-s[T][0]);
每个队做出的题数都在1~N-1的概率为P2=(s[1][N-1]-s[1][0])*(s[2][N-1]-s[2][0])*```(s[T][N-1]-s[T][0]);


最后的答案就是P1-P2,代表至少一个队作出n到以上(“1”-  所有队作出“0~n-1”的概率)



#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
using namespace std;
const int maxn = 1e3 + 5;
double dp[maxn][35][35], p[maxn][35], s[maxn][35];
int m, t, n;
int main()
{
    while(~scanf("%d%d%d", &m, &t, &n), m+n+t)
    {
        for(int i = 1; i <= t; i++)
            for(int j = 1; j <= m; j++)
                scanf("%lf", &p[i][j]);
        memset(dp, 0, sizeof(dp));
        for(int i = 1; i <= t; i++)  //在前0到题作出0到题肯定是1啊
            dp[i][0][0] = 1.0;
        double p1 = 1.0, p2 = 1.0;
        for(int i = 1; i <= t; i++)
        {
            for(int j = 1 ;j <= m; j++)  //然后提前枚举出 前j到作出0到,根据后面的转移方程式发现,会用到这个
                dp[i][j][0]=dp[i][j-1][0]*(1-p[i][j]); 
            for(int j = 1; j <= m; j++)
            {
                for(int k = 1; k <= j; k++)
                {
                    dp[i][j][k] = dp[i][j-1][k-1]*p[i][j]+dp[i][j-1][k]*(1-p[i][j]);
                }
            }
            s[i][0] = dp[i][m][0];
            //s[i][k]=dp[i][M][0]+dp[i][M][1]+``````+dp[i][M][k];
            for(int k = 1; k <= m; k++) //这个是把dp数组写的简单点,代表了 第i个队作出的题少于k道的概率
                s[i][k] = s[i][k-1] + dp[i][m][k];  //肯定是由第i个队所有题总作出1,2,3,....k道的概率和相加
        }
        for(int i = 1; i <= t; i++)
        {
            p1 *= (1-s[i][0]);  //每个队至少一道题的概率(1-每个队一道也做不出来)
            p2 *= (s[i][n-1]-s[i][0]); //每个队做1,-n-1到题的概率,会发现p2属于p1的一种情况,p1现在就相当于“1”;
        
        printf("%.3f\n", p1-p2);
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值