HDU 4405 Aeroplane chess (简单期望)

15 篇文章 2 订阅


Aeroplane chess

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 361    Accepted Submission(s): 255


Problem Description
Hzz loves aeroplane chess very much. The chess map contains N+1 grids labeled from 0 to N. Hzz starts at grid 0. For each step he throws a dice(a dice have six faces with equal probability to face up and the numbers on the faces are 1,2,3,4,5,6). When Hzz is at grid i and the dice number is x, he will moves to grid i+x. Hzz finishes the game when i+x is equal to or greater than N.

There are also M flight lines on the chess map. The i-th flight line can help Hzz fly from grid Xi to Yi (0<Xi<Yi<=N) without throwing the dice. If there is another flight line from Yi, Hzz can take the flight line continuously. It is granted that there is no two or more flight lines start from the same grid.

Please help Hzz calculate the expected dice throwing times to finish the game.
 

 

Input
There are multiple test cases. 
Each test case contains several lines.
The first line contains two integers N(1≤N≤100000) and M(0≤M≤1000).
Then M lines follow, each line contains two integers Xi,Yi(1≤Xi<Yi≤N).  
The input end with N=0, M=0.
 

 

Output
For each test case in the input, you should output a line indicating the expected dice throwing times. Output should be rounded to 4 digits after decimal point.
 

 

Sample Input
2 0 8 3 2 4 4 5 7 8 0 0
 

 

Sample Output
1.1667 2.3441
 

 

Source
 

 

Recommend
zhoujiaqi2010


本题题意:数轴上有N+1个点(编号0~N),一个人玩游戏,从0出发,当到达N或大于N的点则游戏结束。每次行动掷骰子一次,骰子编号1-6,掷到多少就向前走几步,这个数轴上还有些特殊点,这些点类似飞行棋中的飞行点,只要到达这些点就可以直接飞到给定点。求总共投掷骰子次数的期望。

思路:水题,如果有飞机 那么dp[x] = dp[y]就好了, 没有飞机模拟骰子就好了

#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <vector>
using namespace std;
const int maxn = 1e5 + 10;
double dp[maxn];
int book[maxn];
vector<int> v[maxn];
int main()
{
    int n, m;
    while(~scanf("%d%d", &n, &m), n+m)
    {
        int a, b;
        memset(book, 0, sizeof(book));
        memset(dp, 0, sizeof(dp));
        for(int i = 0; i <= n; i++)
            v[i].clear();
        for(int i = 1; i <= m; i++)
        {
            scanf("%d%d", &a, &b);
            v[b].push_back(a);
        }
        for(int i = n; i >= 0; i--)
        {
            if(book[i] && !v[i].size()) continue;
            if(book[i] && v[i].size())
            {
                for(int j = 0; j < v[i].size(); j++)
                    dp[v[i][j]] = dp[i], book[v[i][j]] = 1;
                continue;
            }
            for(int k = 1; k <= 6; k++)
            {
                if(i + k <= n)
                    dp[i] += dp[i+k]/6.0;
            }
            if(i != n) dp[i] += 1.0;
            if(v[i].size())
            {
                for(int j = 0; j < v[i].size(); j++)
                {
                    dp[v[i][j]] = dp[i], book[v[i][j]] = 1;
                }
            }
        }
//        for(int i = 0; i <= n; i++)
//        {
//            printf("%d : %.4f\n", i, dp[i]);
//        }
        printf("%.4f\n", dp[0]);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值