poj 2318 TOYS(叉积)


TOYS
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 14753 Accepted: 7129

Description

Calculate the number of toys that land in each bin of a partitioned toy box. 
Mom and dad have a problem - their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for John to find his favorite toys. 

John's parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example toy box. 
 
For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.

Input

The input file contains one or more problems. The first line of a problem consists of six integers, n m x1 y1 x2 y2. The number of cardboard partitions is n (0 < n <= 5000) and the number of toys is m (0 < m <= 5000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1,y1) and (x2,y2), respectively. The following n lines contain two integers per line, Ui Li, indicating that the ends of the i-th cardboard partition is at the coordinates (Ui,y1) and (Li,y2). You may assume that the cardboard partitions do not intersect each other and that they are specified in sorted order from left to right. The next m lines contain two integers per line, Xj Yj specifying where the j-th toy has landed in the box. The order of the toy locations is random. You may assume that no toy will land exactly on a cardboard partition or outside the boundary of the box. The input is terminated by a line consisting of a single 0.

Output

The output for each problem will be one line for each separate bin in the toy box. For each bin, print its bin number, followed by a colon and one space, followed by the number of toys thrown into that bin. Bins are numbered from 0 (the leftmost bin) to n (the rightmost bin). Separate the output of different problems by a single blank line.

Sample Input

5 6 0 10 60 0
3 1
4 3
6 8
10 10
15 30
1 5
2 1
2 8
5 5
40 10
7 9
4 10 0 10 100 0
20 20
40 40
60 60
80 80
 5 10
15 10
25 10
35 10
45 10
55 10
65 10
75 10
85 10
95 10
0

Sample Output

0: 2
1: 1
2: 1
3: 1
4: 0
5: 1

0: 2
1: 2
2: 2
3: 2
4: 2

Hint

As the example illustrates, toys that fall on the boundary of the box are "in" the box.

【题意】

有一个大箱子,由n个板分为n+1块,标号为0~n已知盒子左上角和右下角的坐标及每个板上下两端的横坐标(板不会交错,且按顺序给出)然后给出玩具的坐标,统计每块空间内玩具个数(保证玩具一定落在空间内)

【解答】

二分,用叉积的性质。

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <cmath>
using namespace std;
const double inf = 1e200;
const double esp = 1e-10;
const double pi = acos(-1.0);
const int maxn = 5050;
int ans[maxn];
struct Point
{
    double x, y;
    Point(double xx = 0, double yy = 0) : x(xx), y(yy){}
};
struct Line
{
    Point s, e;
    Line(){}
    Line(Point ss, Point ee) : s(ss), e(ee){}
};
double xmult(Point sp, Point ep, Point op)
{
    return ((sp.x-op.x)*(ep.y-op.y)-(ep.x-op.x)*(sp.y-op.y));
}
Line line[maxn];
int main()
{
    int n, m, x1, y1, x2, y2;
    int flag = 0;
    while(~scanf("%d", &n), n)
    {
        scanf("%d%d%d%d%d", &m, &x1, &y1, &x2, &y2);
        int s, e;
        for(int i = 0; i < n; i++)
        {
            scanf("%d%d", &s, &e);
            line[i] = Line(Point(s,y1), Point(e, y2));
        }
        line[n] = Line(Point(x2, y1), Point(x2, y2));
        int x, y;
        Point p;
        memset(ans, 0, sizeof(ans));
        while(m--)
        {
            scanf("%d%d", &x, &y);
            p = Point(x, y);
            int l = 0, r = n;
            int temp;
            while(l <= r)
            {
                int mid = (l+r)/2;
                if(xmult(line[mid].s, line[mid].e, p) < 0)  //小于0  在这条线的左面
                {
                    temp = mid;
                    r = mid - 1;
                }
                else l = mid + 1;
            }
            ans[temp]++;
        }
        for(int i = 0; i <= n; i++)
        {
            printf("%d: %d\n", i, ans[i]);
        }
        puts("");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值