二叉排序树

问题:

问题链接:点击打开链接


题目1201:二叉排序树

时间限制:1 秒

内存限制:32 兆

特殊判题:

提交:8316

解决:3564

题目描述:

    输入一系列整数,建立二叉排序数,并进行前序,中序,后序遍历。

输入:

    输入第一行包括一个整数n(1<=n<=100)。
    接下来的一行包括n个整数。

输出:

    可能有多组测试数据,对于每组数据,将题目所给数据建立一个二叉排序树,并对二叉排序树进行前序、中序和后序遍历。
    每种遍历结果输出一行。每行最后一个数据之后有一个空格。

样例输入:
5
1 6 5 9 8
样例输出:
1 6 5 9 8 
1 5 6 8 9 
5 8 9 6 1 
提示:

输入中可能有重复元素,但是输出的二叉树遍历序列中重复元素不用输出。

来源: 2005年华中科技大学计算机保研机试真题

分析:

简单的二叉排序树的操作。

代码:

#include <iostream>
#include <malloc.h>
/* run this program using the console pauser or add your own getch, system("pause") or input loop */
struct Node{
	int data;
	Node * lchild,*rchild;
};
typedef struct Node * Tree;
void init_Tree(Tree t){
	t = (Node *) malloc(sizeof(Node));
	t->lchild=t->rchild = NULL;
}
void insert_T(Tree &t,int x){
	//将结点x插入到二叉排序树t中
	 if(t == NULL){
	 	Node *n = (Node *)malloc(sizeof(Node));
	 	n->data = x;
	 	n->lchild = n->rchild =NULL;
	 	
	 	t = n;
	 } else{
	 	if(x>t->data){
	 		insert_T(t->rchild,x);
		 }else{
		 	insert_T(t->lchild,x);
		 }
	 }
}
void frontTra(Tree t){
	//先序遍历 
	if(t!=NULL) {
		printf("%d",t->data);
	}
	if(t->lchild!= NULL){
		frontTra(t->lchild); 
	}
	if(t->rchild!= NULL){
		frontTra(t->rchild);
	}
}
void midTra(Tree t){
	//中序遍历
	if(t->lchild!= NULL){
		midTra(t->lchild); 
	} 
	if(t!=NULL) {
		printf("%d",t->data);
	}
	if(t->rchild!= NULL){
		midTra(t->rchild);
	}
}
void rearTra(Tree t){
	//后序遍历 
	if(t->lchild!= NULL){
		rearTra(t->lchild); 
	} 

	if(t->rchild!= NULL){
		rearTra(t->rchild);
	}
	if(t!=NULL) {
		printf("%d",t->data);
	}	
}
int main(int argc, char** argv) {
	int n;
	while(scanf("%d",&n)!= EOF){
		Tree t;
		//init_Tree(t);
		
		while(n--){
			int tmp;
			scanf("%d",&tmp);
			insert_T(t,tmp);
		}
		
		frontTra(t);
		printf("\n");
		midTra(t);
		printf("\n");
		rearTra(t);
		
		free(t);
	}
	
	 
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值