PAT乙级-1029 旧键盘 (20分)

点击链接PAT乙级-AC全解汇总

题目:
旧键盘上坏了几个键,于是在敲一段文字的时候,对应的字符就不会出现。现在给出应该输入的一段文字、以及实际被输入的文字,请你列出肯定坏掉的那些键。

输入格式:
输入在 2 行中分别给出应该输入的文字、以及实际被输入的文字。每段文字是不超过 80 个字符的串,由字母 A-Z(包括大、小写)、数字 0-9、以及下划线 _(代表空格)组成。题目保证 2 个字符串均非空。

输出格式:
按照发现顺序,在一行中输出坏掉的键。其中英文字母只输出大写,每个坏键只输出一次。题目保证至少有 1 个坏键。

输入样例:

7_This_is_a_test
_hs_s_a_es

输出样例:

7TI

我的代码:

#include<iostream>
#include<cstdio>
#include<string>
#include<algorithm>
#include<cstring>
#include<vector>
#include<math.h>
#include<time.h>
using namespace std;

int main()
{
    char strin[80],strout[80];
    cin>>strin>>strout;
    int len1=strlen(strin);
    int len2=strlen(strout);
    int i=0,j=0;
    int ascii[128]={0};
    bool flag_=true;
    for(i=0;i<len1;i++)
    {
        if(strin[i]==strout[j])j++;
        else
        {//loss
            if(strin[i]>='0'&&strin[i]<='9'&&ascii[(int)strin[i]]!=1)
            {//0-9
                cout<<strin[i];
                ascii[(int)strin[i]]=1;
            }
            else if(strin[i]>='A'&&strin[i]<='Z'&&ascii[(int)strin[i]]!=1)
            {//A-Z
                cout<<strin[i];
                ascii[(int)strin[i]]=1;
            }
            else if(strin[i]>='a'&&strin[i]<='z')
            {//a-z to A-Z
                strin[i]=strin[i]-'a'+'A';
                if(ascii[(int)strin[i]]==0)cout<<strin[i];
                ascii[(int)strin[i]]=1;
            }
            else if(strin[i]=='_'&&flag_)
            {//_
                cout<<'_';
                flag_=false;
            }
        }
    }

    return 0;
}

有的时候题目是一起做的,所以会有不需要的头文件

注意空格也算一个按键,不然一个case一直错误

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值