PAT甲级-1001 A+B Format (20分)

点击链接PAT乙级-AC全解汇总

点击链接PAT甲级-AC全解汇总

题目:
Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −10​6​​ ≤a,b≤10​6​​ . The numbers are separated by a space.

Output Specification:
For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

题意:
求两个数字的和,然后每三位插一个逗号

我的代码:

#include<bits/stdc++.h>
using namespace std;

int main()
{
    int a,b;
    cin>>a>>b;
    string str=to_string(a+b);
    reverse(str.begin(),str.end());
    int index=0,flag=1;
    while(index<str.length())
    {
        if(flag%4==0&&str[index]!='-')
        {
            str.insert(index,",");
            index++;
            flag=1;
        }
        index++;
        flag++;
    }
    reverse(str.begin(),str.end());
    cout<<str<<endl;
    return 0;
}

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值