PAT甲级-1043 Is It a Binary Search Tree (25分)

点击链接PAT甲级-AC全解汇总

题目:
A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node’s key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
  • Both the left and right subtrees must also be binary search trees.

If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.

Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:
For each test case, first print in a line YES if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or NO if not. Then if the answer is YES, print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

7
8 6 5 7 10 8 11

Sample Output 1:

YES
5 7 6 8 11 10 8

Sample Input 2:

7
8 10 11 8 6 7 5

Sample Output 2:

YES
11 8 10 7 5 6 8

Sample Input 3:

7
8 6 8 5 10 9 11

Sample Output 3:

NO

题意:
输入一个数,组成查找树,并判断输入的顺序是先序或者镜像先序,如果是的话,输出后序或镜像后序,如果不是直接输出NO

让我自己写可能写不到算法笔记那么好,我直接附上之前算法笔记的代码好了。

算法笔记的代码:

#include<bits/stdc++.h>
using namespace std;
#define null 0
struct node{
    int data;
    node *lchild,*rchild;
};
vector<int>origin,pre,prem,post,postm;
void my_p(vector<int>vec){
    for(auto it:vec)cout<<it<<" ";
    cout<<endl;
}
void insert(node* &root,int data){
    if(root==null){
        root=new node;
        root->data=data;
        root->lchild=root->rchild=null;
        return;
    }
    if(data<root->data)
        insert(root->lchild,data);
    else
        insert(root->rchild,data);
}

//preorder
void preorder(node* root,vector<int>&vi){
    if(root==null)return;
    vi.push_back(root->data);
    preorder(root->lchild,vi);
    preorder(root->rchild,vi);
}
//preordernmirror
void preordernmirror(node* root,vector<int>&vi){
    if(root==null)return;
    vi.push_back(root->data);
    preordernmirror(root->rchild,vi);
    preordernmirror(root->lchild,vi);
}
//postorder
void postorder(node* root,vector<int>&vi){
    if(root==null)return;
    postorder(root->lchild,vi);
    postorder(root->rchild,vi);
    vi.push_back(root->data);
}
//postordernmirror
void postordernmirror(node* root,vector<int>&vi){
    if(root==null)return;
    postordernmirror(root->rchild,vi);
    postordernmirror(root->lchild,vi);
    vi.push_back(root->data);
}

int main(){
    int n,data;
    node* root=null;
    scanf("%d",&n);
    for(int i=0;i<n;i++){
        scanf("%d",&data);
        origin.push_back(data);
        insert(root,data);
    }
    preorder(root,pre);
    preordernmirror(root,prem);
    postorder(root,post);
    postordernmirror(root,postm);

    if(origin==pre)
    {
        printf("YES\n");
        for(int i=0;i<post.size();i++)
        {
            if(i>0)printf(" ");
            printf("%d",post[i]);
        }
    }
    else if(origin==prem)
    {
        printf("YES\n");
        for(int i=0;i<postm.size();i++)
        {
            if(i>0)printf(" ");
            printf("%d",postm[i]);
        }
    }
    else printf("NO\n");
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值