lightoj 1138 (二分)

lightoj 1138

Time Limit: 2000MS      Memory Limit: 32768KB      64bit IO Format: %lld & %llu

Description

You task is to find minimal natural number N, so that N! contains exactly Q zeroes on the trail in decimal notation. As you know N! = 1*2*...*N. For example, 5! = 120, 120 contains one zero on the trail.

Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case contains an integer Q (1 ≤ Q ≤ 108) in a line.

Output

For each case, print the case number and N. If no solution is found then print 'impossible'.

Sample Input

3

1

2

5

Sample Output

Case 1: 5

Case 2: 10

Case 3: impossible

【题意】有些N!的末尾会是几个连续的0,找含Q个0的N!的最小N值;

【思路】用二分法,从区间【0, oo(无穷大)】查找,注意判断N!的末尾有几个0,。



AC代码:

#include<cstdio>
#define LL long long
LL sum(LL N)//求N阶乘中 末尾连续的0的个数
{
    LL ans = 0;
    while(N)
    {
        ans += N / 5;
        N /= 5;
    }
    return ans;
}
int k = 1;
int main()
{
    int t;
    LL Q;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%lld", &Q);
        LL left = 1, right = 1000000000000;
        LL ans = 0;
        while(right >= left)
        {
            int mid = (left + right) >> 1;
            if(sum(mid) == Q)//相等时 要赋值给ans
            {
                ans = mid;
                right = mid - 1;//找的是最小的ans
            }
            else if(sum(mid) > Q)
                right = mid - 1;
            else
                left = mid + 1;
        }
        printf("Case %d: ", k++);
        if(ans)
            printf("%lld\n", ans);
        else
            printf("impossible\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值