LightOJ 1138(求末尾零个数) 二分+数学

题意:

N!后面有Q个0,给你Q,求最小的N




Input

starts with an integer T (≤ 10000), denoting the number of test cases.

Each case contains an integer Q (1 ≤ Q ≤ 108) in a line.

Output

For each case, print the case number and N. If no solution is found then print 'impossible'.

Sample Input

3

1

2

5

Sample Output

Case 1: 5

Case 2: 10

Case 3: impossible


思路:阶乘的所有数拆分成质因子的乘积,发现只有2*5才能生成0,2很多,看5的个数即为末尾0的个数。

求5的个数的方法:例如求25!,25/5=5,5/5=1,故有5+1=6个5。但是本题给0个数求n,故要在茫茫中寻找,果断二分。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#define N 15006
#define LL long long
using namespace std;
int f(int n)//求n的阶乘末尾0的个数
{
    int ans=0;
    while(n)
    {
        ans+=n/5;
        n=n/5;
    }
    return ans;
}
int main()
{
    int t,n,cat=0,mid;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        int l=0,r=1e9;
        while(l<=r)
        {
            mid=(l+r)>>1;
            if(f(mid)>=n)
                r=mid-1;
            else
                l=mid+1;

        }
        if(f(l)==n)
            printf("Case %d: %d\n",++cat,l);
        else
            printf("Case %d: impossible\n",++cat);
    }
    return 0;
}
如果求最大的n,则二分要这样写:

while(l<=r) //输出最大值
{
    mid=(l+r)>>1;
    if(f(mid)>n)
        r=mid-1;
    else if(f(mid)<=n)
        l=mid+1;
}
if(f(r)==n)
    printf("Case %d: %d\n",++cat,r);
else
    printf("Case %d: impossible\n",++cat);




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值