poj 3041 Asteroids【二分图】【匈牙利算法】

Asteroids

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid. 

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space. 
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2

Hint

INPUT DETAILS: 
The following diagram represents the data, where "X" is an asteroid and "." is empty space: 
X.X 
.X. 
.X.
 

OUTPUT DETAILS: 
Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).

Source



【题意】
给出一个地图,把每一行或列的‘X’改为‘.’为一次操作,问最少操作几次可以把所有的'X'改为‘.’。

【题解】
将地图的行列看做俩不同的集合a b,然后每个'X'的坐标看做连接集合a b的线,就转化为二分图的最大匹配问题。



AC代码:
#include<cstdio>
#include<string.h>
#include<algorithm>
using namespace std;
int map[505][505];
int ans[10005];//记录是否被询问过 
int link[10005];//记录寻找到的搭档 
int n, k;
bool dfs(int x)
{
	for(int i = 1; i <= n; i++)
	{
		if(map[x][i] && !ans[i])
		{
			ans[i] = 1;
			if(link[i] == -1 || dfs(link[i])) 
			{
				link[i] = x;
				return true;
			}
		}
	}
	return false;
}
int  main()  
{  
    while(scanf("%d%d",&n,&k)!=EOF)  
    {  
        int sum=0;  
        int a,b;  
        memset(link,-1,sizeof(link));  
        memset(map,0,sizeof(map));  
        for(int i=1;i<=k;i++)  
		{  
			scanf("%d %d",&a,&b);  
			map[a][b]=1;  
		}  
		for(int i = 1; i <= n; i++)
		{
			memset(ans, 0, sizeof(ans));
			if(dfs(i))
				sum++;
		}
        printf("%d\n",sum);  
    }  
}  
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值