Average Score

 

 

Average Score

 

 

Bob is a freshman in Marjar University. He is clever and diligent. However, he is not good at math, especially in Mathematical Analysis.

After a mid-term exam, Bob was anxious about his grade. He went to the professor asking about the result of the exam. The professor said:

"Too bad! You made me so disappointed."

"Hummm... I am giving lessons to two classes. If you were in the other class, the average scores of both classes will increase."

Now, you are given the scores of all students in the two classes, except for the Bob's. Please calculate the possible range of Bob's score. All scores shall be integers within [0, 100].

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains two integers N (2 <= N <= 50) and M (1 <= M <= 50) indicating the number of students in Bob's class and the number of students in the other class respectively.

The next line contains N - 1 integers A1, A2, .., AN-1 representing the scores of other students in Bob's class.

The last line contains M integers B1, B2, .., BM representing the scores of students in the other class.

<h4< dd="">

Output

For each test case, output two integers representing the minimal possible score and the maximal possible score of Bob.

It is guaranteed that the solution always exists.

<h4< dd="">

Sample Input

2
4 3
5 5 5
4 4 3
6 5
5 5 4 5 3
1 3 2 2 1

<h4< dd="">

Sample Output

4 4
2 4

 

 

题意:给出两组数,我们求一个数比第一组的平均数低,比第二组的平均数高。求这个数的范围。这是一道水题,简单模拟。

Code:

#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
int T,n,m;
int main(){
	scanf("%d",&T);
	while (T--){
		int sumx=0,sumy=0,minans=0,maxans=0;
		double avex=0,avey=0;
		scanf("%d%d",&n,&m);
		for (int i=1;i<n;i++){
			int x;
			scanf("%d",&x);
			sumx+=x;
			avex=(double)sumx/(double)(n-1);
		}
		for (int i=1;i<=m;i++){
			int y;
			scanf("%d",&y);
			sumy+=y;
			avey=(double)(sumy)/(double)m;
		}
		for (int i=1;i<=100;i++){
			double x=(double)(sumx+i)/(double)n;
			double y=(double)(sumy+i)/(double)(m+1);
			if (avex>x && y>avey){
				minans=i;
				break;
			}
		}
		for (int i=100;i>=1;i--){
			double x=(double)(sumx+i)/(double)n;
			double y=(double)(sumy+i)/(double)(m+1);
			if (avex>x && y>avey){
				maxans=i;
				break;
			}
		}
		printf("%d %d\n",minans,maxans);
	}
} 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

JackflyDC

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值