hdu4280 (网络流大水题)--by lethalboy

Island Transport

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 7926    Accepted Submission(s): 2494


Problem Description
  In the vast waters far far away, there are many islands. People are living on the islands, and all the transport among the islands relies on the ships.
  You have a transportation company there. Some routes are opened for passengers. Each route is a straight line connecting two different islands, and it is bidirectional. Within an hour, a route can transport a certain number of passengers in one direction. For safety, no two routes are cross or overlap and no routes will pass an island except the departing island and the arriving island. Each island can be treated as a point on the XY plane coordinate system. X coordinate increase from west to east, and Y coordinate increase from south to north.
  The transport capacity is important to you. Suppose many passengers depart from the westernmost island and would like to arrive at the easternmost island, the maximum number of passengers arrive at the latter within every hour is the transport capacity. Please calculate it.
 

Input
  The first line contains one integer T (1<=T<=20), the number of test cases.
  Then T test cases follow. The first line of each test case contains two integers N and M (2<=N,M<=100000), the number of islands and the number of routes. Islands are number from 1 to N.
  Then N lines follow. Each line contain two integers, the X and Y coordinate of an island. The K-th line in the N lines describes the island K. The absolute values of all the coordinates are no more than 100000.
  Then M lines follow. Each line contains three integers I1, I2 (1<=I1,I2<=N) and C (1<=C<=10000) . It means there is a route connecting island I1 and island I2, and it can transport C passengers in one direction within an hour.
  It is guaranteed that the routes obey the rules described above. There is only one island is westernmost and only one island is easternmost. No two islands would have the same coordinates. Each island can go to any other island by the routes.
 

Output
  For each test case, output an integer in one line, the transport capacity.
 

Sample Input
      
      
2 5 7 3 3 3 0 3 1 0 0 4 5 1 3 3 2 3 4 2 4 3 1 5 6 4 5 3 1 4 4 3 4 2 6 7 -1 -1 0 1 0 2 1 0 1 1 2 3 1 2 1 2 3 6 4 5 5 5 6 3 1 4 6 2 5 5 3 6 4
Sample Output
       
       
9 6
 题意:有N个岛屿之间有M双向条路,每条路每个小时最多能通过C个人,现在问一个小时内,最多能把多少个顾客从最西边的岛屿送至最东边的岛屿上
分析:裸的网络流,随便写写就过了,只是很不理解,这么大的数据,这么水的题,不烦吗?
注意:此图为无向图,原点汇点不定,故无向边要加成两条有向边,那么根据残量网络求最大流原理
附代码:
#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<algorithm>
#include<cstring>
#include<queue>
#define N 100001
#define M 800001
#define inf 0x7fffffff
using namespace std;
int head[N],pos,cur[N];
int n,m;
struct edge
{int to,next,c;}e[M];
void add(int a,int b,int c)
{e[pos].to=b,e[pos].next=head[a],e[pos].c=c;head[a]=pos;pos++;}
queue<int>q;
int d[N];bool vis[N];
int s,t;
int ex,wx;
bool bfs()
{
    while(!q.empty())q.pop();
    for(int i=1;i<=n;i++)    
        vis[i]=0;
    d[s]=1;vis[s]=1;
    q.push(s);
    while(!q.empty())
        {
            int u=q.front();
            q.pop();
            for(int i=head[u];i!=-1;i=e[i].next)
                {
                    int v=e[i].to;
                    if(vis[v]||e[i].c<=0)continue;
                    d[v]=d[u]+1;
                    vis[v]=1;
                    q.push(v);
                }
        }
    return vis[t];
}
int dfs(int u,int a)
{
    if(u==t||a==0)return a;
    int f,flow=0;
    for(int &i=cur[u];i!=-1;i=e[i].next)
        {
            int v=e[i].to;
            if(d[v]==d[u]+1&&(f=dfs(v,min(a,e[i].c)))>0)
                {
                    e[i].c-=f;
                    e[i^1].c+=f;
                    flow+=f;
                    a-=f;
                    if(a==0)break;
                }
        }
    return flow;
}
int dinic()
{
    int ans=0;
    while(bfs())
        {
            for(int i=1;i<=n;i++)
                cur[i]=head[i];
            ans+=dfs(s,inf);
        }
    return ans;
}
int T;
int a,b,c;
int x,y;
void init()
{
    memset(head,-1,sizeof(head));
    pos=0;
}
int main()
{
    scanf("%d",&T);
    while(T--)
        {
            init();
            ex=-inf,wx=inf;
            scanf("%d%d",&n,&m);
            for(int i=1;i<=n;i++)
                {
                    scanf("%d%d",&x,&y);
                    if(x<wx)wx=x,s=i;
                    else if(x>ex)ex=x,t=i;
                }
            for(int i=1;i<=m;i++)
                {
                    scanf("%d%d%d",&a,&b,&c);
                    add(a,b,c);
                    add(b,a,c);
                }
            printf("%d\n",dinic());
        }
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值