1652: [Usaco2006 Feb]Treats for the Cows
Time Limit: 5 Sec Memory Limit: 64 MBSubmit: 361 Solved: 281
[ Submit][ Status][ Discuss]
Description
FJ has purchased N (1 <= N <= 2000) yummy treats for the cows who get money for giving vast amounts of milk. FJ sells one treat per day and wants to maximize the money he receives over a given period time. The treats are interesting for many reasons: * The treats are numbered 1..N and stored sequentially in single file in a long box that is open at both ends. On any day, FJ can retrieve one treat from either end of his stash of treats. * Like fine wines and delicious cheeses, the treats improve with age and command greater prices. * The treats are not uniform: some are better and have higher intrinsic value. Treat i has value v(i) (1 <= v(i) <= 1000). * Cows pay more for treats that have aged longer: a cow will pay v(i)*a for a treat of age a. Given the values v(i) of each of the treats lined up in order of the index i in their box, what is the greatest value FJ can receive for them if he orders their sale optimally? The first treat is sold on day 1 and has age a=1. Each subsequent day increases the age by 1.
约翰经常给产奶量高的奶牛发特殊津贴,于是很快奶牛们拥有了大笔不知该怎么花的钱.为此,约翰购置了N(1≤N≤2000)份美味的零食来卖给奶牛们.每天约翰售出一份零食.当然约翰希望这些零食全部售出后能得到最大的收益.这些零食有以下这些有趣的特性:
Input
* Line 1: A single integer,
N * Lines 2..N+1: Line i+1 contains the value of treat v(i)
Output
* Line 1: The maximum revenue FJ can achieve by selling the treats
Sample Input
1
3
1
5
2
Five treats. On the first day FJ can sell either treat #1 (value 1) or
treat #5 (value 2).
Sample Output
OUTPUT DETAILS:
FJ sells the treats (values 1, 3, 1, 5, 2) in the following order
of indices: 1, 5, 2, 3, 4, making 1x1 + 2x2 + 3x3 + 4x1 + 5x5 = 43.
HINT
Source
本以为这道题和bzoj1640相像,可以贪心搞搞,wa了之后发现由于有乘法干预,不一定满足局部最优=全局最优,所以要dp搞搞。
记忆化搜索。方程:dp(x,y)=max( dp(x+1,y)+a[x]*(n-(y-x+1)+1), dp(x,y-1)+a[y]*(n-(y-x+1)+1) )
附代码:
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstdlib>
#include<cmath>
#include<climits>
#include<cstring>
#include<string>
#include<queue>
#include<map>
#include<set>
#define N 2002
using namespace std;
int n,ans;
int f[N][N],a[N];
int dp(int x,int y)
{
if(f[x][y])return f[x][y];
if(x==y)return f[x][y]=a[x]*n;
int &t=f[x][y];
t=max(t,dp(x+1,y)+(n-y+x)*a[x]);
t=max(t,dp(x,y-1)+(n-y+x)*a[y]);
return t;
}
int main()
{
scanf("%d",&n);
for(int i=1;i<=n;i++)scanf("%d",&a[i]);
printf("%d\n",dp(1,n));
}