【PAT甲级】1050 String Subtraction(散列)

Given two strings S​1​​ and S​2​​, S=S​1​​−S​2​​ is defined to be the remaining string after taking all the characters in S​2​​ from S​1​​. Your task is simply to calculate S​1​​−S​2​​ for any given strings. However, it might not be that simple to do it fast.

Input Specification:

Each input file contains one test case. Each case consists of two lines which gives S​1​​ and S​2​​, respectively. The string lengths of both strings are no more than 10​4​​. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

Output Specification:

For each test case, print S​1​​−S​2​​ in one line.

Sample Input:

They are students.
aeiou

Sample Output:

Thy r stdnts.

题目大意

这题就是给出两个字符串,然后把第一个字符串中在第二个字符串里出现的字符去掉之后再输出即可。

个人思路

这题是散列算法的应用,将第二个字符串中的所有字符是否出现映射在一个bool型 数组中,如果第一个字符串中的字符被标记了则不输出,否则则输出。

代码实现

#include <cstdio>
#include <cstring>
#include <string>
#include <set>
#include <map>
#include <vector>
#include <cmath>
#include <algorithm>
#include <iostream>
#define ll long long
#define eps 1e-8
#define INF 0x7FFFFFFF
using namespace std;

int main() {
    // 输入
    string s1, s2;
    getline(cin, s1);
    getline(cin, s2);

    // 初始化映射数组
    bool flag[200];
    memset(flag, 0, sizeof(flag));
    
    // 标记s2中出现的字符
    for (int i = 0; i < s2.length(); i ++) {
        flag[s2[i]] = true;
    }
    
    // 将s1中未被标记的字符输出
    for (int i = 0; i < s1.length(); i ++) {
        if (!flag[s1[i]]) cout << s1[i];
    }
    return 0;
}

总结

学习不息,继续加油

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值