PAT - 甲级 - 1108. Finding Average (20) ( 字符串处理 sscanf )

Given an integer with no more than 9 digits, you are supposed to read it in the traditional Chinese way. Output "Fu" first if it is negative. For example, -123456789 is read as "Fu yi Yi er Qian san Bai si Shi wu Wan liu Qian qi Bai ba Shi jiu". Note: zero ("ling") must be handled correctly according to the Chinese tradition. For example, 100800 is "yi Shi Wan ling ba Bai".

Input Specification:

Each input file contains one test case, which gives an integer with no more than 9 digits.

Output Specification:

For each test case, print in a line the Chinese way of reading the number. The characters are separated by a space and there must be no extra space at the end of the line.

Sample Input 1:
-123456789
Sample Output 1:
Fu yi Yi er Qian san Bai si Shi wu Wan liu Qian qi Bai ba Shi jiu
Sample Input 2:
100800
Sample Output 2:
yi Shi Wan ling ba Bai

给定条件:
1.n个数字
2.其中有“非法数字”

要求:
1.合法数字的和的平均数
2.非法数字有哪些

求解:
1.判断数字是否合法,可以先把字符串转化成数字,然后数字再转换成字符串,和原来的字符串相比较,如果不同,则是非法数字。


#include <cstdio>
#include <cctype>
#include <cstring>
#include <iostream>
#include <vector>

using namespace std;

int n, cnt = 0;
vector<string> error;
char input[50], temp[50];
double sum = 0;
double num;
int main() {
	scanf("%d", &n);
	for(int i = 0; i < n; i++) {
		int flag = 1;
		scanf("%s", input);

		sscanf(input,"%lf",&num);
		sprintf(temp,"%.2lf", num);

		for(int i = 0; i < strlen(input); i++) {
			if(temp[i] != input[i]) {
				flag = 0;
				break;
			}
		}
		if(flag && num >= -1000 && num <= 1000) {
			sum += num;
			cnt++;
		} else {
			error.push_back(input);
		}
	}
	for(int i = 0; i < error.size(); i++) {
		printf("ERROR: %s is not a legal number\n", error[i].c_str());
	}
	if(n - error.size() == 1) {
		printf("The average of 1 number is %.2f\n", sum);
	} else if(error.size() == n) {
		printf("The average of 0 numbers is Undefined\n");
	} else {
		printf("The average of %d numbers is %.2f\n", cnt, sum/cnt);
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值