PAT - 甲级 - 1053. Path of Equal Weight (30)(树的DFS搜索+排序)

Given a non-empty tree with root R, and with weight Wi assigned to each tree node Ti. The weight of a path from R to Lis defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.

Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let's consider the tree showed in Figure 1: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in Figure 1.


Figure 1

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0 < N <= 100, the number of nodes in a tree, M (< N), the number of non-leaf nodes, and 0 < S < 230, the given weight number. The next line contains N positive numbers where Wi (<1000) corresponds to the tree node Ti. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 00.

Output Specification:

For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

Note: sequence {A1, A2, ..., An} is said to be greater than sequence {B1, B2, ..., Bm} if there exists 1 <= k < min{n, m} such that Ai = Bifor i=1, ... k, and Ak+1 > Bk+1.

Sample Input:
20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19
Sample Output:
10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2


给定条件:
1.n个节点和节点的权重
2.节点间连接

要求:
1.从根节点出发到叶子节点的路线中节点权重之和是给定值的路线
2.存在多条路线,根据给定的要求按照顺序输出

解决:
1.从根结点开始搜索,搜索边界为(1找到叶子节点 2当前和已超过给定数值)
2.如果搜索到叶子节点要判断当前和是否等于给定值。如果符合则该路线是符合条件的
3.将搜索到的路线存放到容器中
4.将路线按照给定要求进行排序,然后输出结果


#include<cstdio>
#include<vector>
#include<algorithm>
using namespace std;

int n, m, s, w[110];
int father, k, son;
bool vis[110];
vector<int> e[110];
vector<int> path;
vector< vector<int> > ans;

void dfs(int cur, int sum){
	
	if(e[cur].size() == 0){
		if(sum == s){
			ans.push_back(path);
		}
		return ;
	}
	if(sum > s){
		return ;
	}

	for(int i = 0; i < e[cur].size(); i++){
		int next = e[cur][i];
		if(vis[next] == false){
			vis[next] = true;
			path.push_back(w[next]);
			dfs(next, sum+w[next]);
			path.pop_back();
			vis[next] = false;
		}
	}
}
int main(){
	while(scanf("%d%d%d",&n, &m, &s) != EOF){
	
		fill(vis, vis+110, false);
		// input
		for (int i = 0; i < n; i++){
			scanf("%d",&w[i]);
		}
		for (int i = 0; i < m; i++){
			scanf("%d%d",&father, &k);
			for(int i = 0; i < k; i++){
				scanf("%d", &son);
				e[father].push_back(son);
			}
		}
		// dfs
		vis[0] = true;
		path.push_back(w[0]);
		dfs(0,w[0]);
		// output
		sort(ans.begin(),ans.end());
		for(int i = ans.size()-1; i >= 0; i--){
			for(int j = 0; j < ans[i].size(); j++){
				if(j!=0) printf(" ");
				printf("%d", ans[i][j]);
				
			}
			printf("\n");
		}
	}

	return 0;
}




  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值