PAT - 甲级 - 1064. Complete Binary Search Tree (30)(完全二叉搜索树层次遍历)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key. 
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key. 
  • Both the left and right subtrees must also be binary search trees. 

A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:
10
1 2 3 4 5 6 7 8 9 0
Sample Output:
6 3 8 1 5 7 9 0 2 4


给定条件:
1.给定n个节点
2.这n个节点是属于一颗二叉搜索树的节点,并且这棵树是完全二叉树

要求:
1.这棵树的层次遍历结果

求解:
1.因为是二叉搜索树,所以将n个节点排序后可得到该二叉树中序遍历的结果
2.如果根节点的编号为x,那么它的左子树根节点是2*x,右子树根节点是2*x+1 (x!=0),编号顺序即层次遍历顺序
3.根据中序遍历结果,更新层次遍历中的节点信息


#include<cstdio>
#include<algorithm>
using namespace std;

int n, id;
int a[1005];
int ans[1005];

void dfs(int index){
	if(index > n) return ;

	dfs(index*2);
	ans[index] = a[id++]; 
	dfs(index*2+1);
}
int main(){
	while(scanf("%d",&n) != EOF){
		id = 1;
		for(int i = 1; i <= n; i++){
			scanf("%d",&a[i]);
		}
		sort(a+1,a+n+1);
		dfs(1);
		for(int i = 1; i <= n; i++){
			if(i!=1) printf(" ");
			printf("%d", ans[i]);
		}
	}
	return 0;
}




  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值