《算法笔记》3.1小节——入门模拟->简单模拟——Shortest Distance

题目描述

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

输入格式

Each input file contains one test case. For each case, the first line contains an integer N (in [3,10​5​​]), followed by N integer distances D​1​​ D​2​​⋯ D​N​​, where D​i​​ is the distance between the i-th and the (i+1)-st exits, and D​N​​ is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤10​4​​), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 10​7​​.

输出格式

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.
输入样例
5 1 2 4 14 9
3
1 3
2 5
4 1

输出样例

3
10
7

题目意思是求一个环形路线两节点之间的最短距离
思路:最开始是想累加,用一个变量将总距离求出,然后求两节点顺时针距离,然后用总距离减去顺时针距离即可求得逆时针距离,然后比较,小的即为最短距离。但提交之后超时!只能另寻它路,发现环形路线的总距离是可求的,A到B之间的距离等于(A到0距离)减去(B到0距离),任意节点到0的距离都可以在输入时求出。
代码如下
#include<stdio.h>
int main()
{
    int n,i,total = 0;
    scanf("%d",&n);
    int a[n],d;
    for(i = 0;i <n; i++){
        scanf("%d",&d);
        a[i+1] = total;//每个节点到初始位置的距离
        total += d;//环形路线的总距离
    }
    int m,start,end,sum;
    scanf("%d",&m);
    for(i = 0;i < m; i++){
        scanf("%d%d",&start,&end);
        if(start>end){
            sum = a[start]-a[end];//两个节点之间的距离
        }
        else{
            sum = -a[start]+a[end];
        }
        if(total - sum > sum)
            printf("%d\n",sum);
        else
            printf("%d\n",total-sum);
    }
    return 0;
}

作为一个刚开始刷题的小白,还有很多难题等着我,为了更好的明天,努力吧,少年!

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值