pat-1046 Shortest Distance(20)(简单题)

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3,10​5​​]), followed by N integer distances D​1​​ D​2​​ ⋯ D​N​​, where D​i​​ is the distance between the i-th and the (i+1)-st exits, and D​N​​ is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤10​4​​), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 10​7​​.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:

5 1 2 4 14 9
3
1 3
2 5
4 1

Sample Output:

3
10
7

 

思路很简单,就是正着走路短,还是逆着走路短,要注意一下先把sum存起来省点时间就行。 

#include<cstdio>
#include <cstring>
#include<algorithm>
#include <iostream>
#include <cmath>
using namespace std;
const int maxn = 1e5 + 5;
int a[maxn],c[maxn];
int main()
{
  
    int n,m,x,y,sum ,total = 0,res;
    scanf("%d",&n);
    if(n < 3)
        return 0;
    for(int i = 1 ; i <= n ; i ++)
    {
       
        scanf("%d",&a[i]);
        total += a[i];
        c[i] = total;//牺牲空间 减少时间,先存起来
    }
  
    scanf("%d",&m);
    for(int i = 0 ; i < m;i++)
    {
        sum = 0;
        res = 0;
        scanf("%d%d",&x,&y);
        if(x > y)
            swap(x,y);
//        for(int j = x ; j < y;j++)//每次都加一遍最后一个测试点超时
//            sum += a[j];
        sum = c[y - 1] - c[x - 1];
        res = min(sum , total - sum);
        cout<<res<<endl;
    }
    return 0;
}

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值