PAT - 甲级 - 1067. Sort with Swap(0,*) (25)(模拟+贪心)

Given any permutation of the numbers {0, 1, 2,..., N-1}, it is easy to sort them in increasing order. But what if Swap(0, *) is the ONLY operation that is allowed to use? For example, to sort {4, 0, 2, 1, 3} we may apply the swap operations in the following way:

Swap(0, 1) => {4, 1, 2, 0, 3}
Swap(0, 3) => {4, 1, 2, 3, 0}
Swap(0, 4) => {0, 1, 2, 3, 4}

Now you are asked to find the minimum number of swaps need to sort the given permutation of the first N nonnegative integers. 

Input Specification:

Each input file contains one test case, which gives a positive N (<=105) followed by a permutation sequence of {0, 1, ..., N-1}. All the numbers in a line are separated by a space.

Output Specification:

For each case, simply print in a line the minimum number of swaps need to sort the given permutation.

Sample Input:
10 3 5 7 2 6 4 9 0 8 1
Sample Output:
9

给定条件:
1.一个数列
2.一种操作,第一个数字可以和任意位置元素进行交换

要求:
1.最少经过几次操作,能使得给定序列呈升序

求解:
1.直接把第一个位置上的数字放到它应该在的地方一定能保证操作为最少次数
2.但是第一个位置上的数字就应该在第一个位置上,别的位置上也可能有不在属于自己的位置上的元素,但是这个元素要放到应该在的位置首先必须和第一个位置交换
3.因此模拟此过程,即可求的最少次数


#include <cstdio>
#include <vector>
#include <algorithm>
#include <map>
using namespace std;

int n, t, ans = 0;
vector<int> v, sorted;
map<int, int> m;

int main() {
	scanf("%d", &n);
	for(int i = 0; i < n; i++) {
		scanf("%d", &t);
		v.push_back(t);
		sorted.push_back(t);
	}
	sort(sorted.begin(), sorted.end());
	for(int i = 0; i < n; i++) {
		m[sorted[i]] = i;
	}

	int i = 0;
	while(true) {
		while(m[v[0]] != 0) {
			swap(v[0], v[m[v[0]]]);
			ans++;
		}
		int flag = 1;
		for( ; i < n; i++) {
			if(m[v[i]] != i) {
				swap(v[0], v[i]);
				ans++;
				flag = 0;
				break;
			}
		}
		if(flag) {
			break;
		}
	}
	printf("%d\n", ans);
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值