PAT甲级.1077. Kuchiguse (20)

1077. Kuchiguse (20)


题目

The Japanese language is notorious for its sentence ending particles. Personal preference of such particles can be considered as a reflection of the speaker’s personality. Such a preference is called “Kuchiguse” and is often exaggerated artistically in Anime and Manga. For example, the artificial sentence ending particle “nyan~” is often used as a stereotype for characters with a cat-like personality:

Itai nyan~ (It hurts, nyan~)
Ninjin wa iyada nyan~ (I hate carrots, nyan~)
Now given a few lines spoken by the same character, can you find her Kuchiguse?

输入格式

Each input file contains one test case. For each case, the first line is an integer N (2<=N<=100). Following are N file lines of 0~256 (inclusive) characters in length, each representing a character’s spoken line. The spoken lines are case sensitive.

输出格式

For each test case, print in one line the kuchiguse of the character, i.e., the longest common suffix of all N lines. If there is no such suffix, write “nai”.

输入样例1

3
Itai nyan~
Ninjin wa iyadanyan~
uhhh nyan~

输出样例1

nyan~

输入样例2

3
Itai!
Ninjinnwaiyada T_T
T_T

输出样例2

nai

PAT链接


思路

1.取第一个读取的字符串反转后存入ans[]内,之后对每个读入的字符串反转之后与ans从头到后比较,发现不同字符跳出,将之前相同的字符串再更新到ans中
2.将ans反转输出


代码

/**
* @tag     PAT_A_1077
* @authors R11happy (xushuai100@126.com)
* @date    2016-8-30 23:56-00:30
* @version 1.0
* @Language C++
* @Ranking  380/2402
* @function null
*/

#include <cstdio>
#include <cstdlib>
#include <cstring>

char str[110][260];

//反转字符串
void reverse(char s[])
{
    int len = strlen(s);
    for (int i = 0; i<len / 2; i++)
    {
        int tmp = s[i];
        s[i] = s[len - 1 - i];
        s[len - 1 - i] = tmp;
    }
}

int main(int argc, char const *argv[])
{
    int N,j;
    char ans[260];
    scanf("%d", &N);
    getchar();
    gets(ans);
    reverse(ans);
    for (int i = 1; i<N; i++)
    {
        char tmp[260];
        gets(str[i]);
        reverse(str[i]);
        int len_ans = strlen(ans);
        int len_str = strlen(str[i]);
        int len = len_ans > len_str ? len_str : len_ans;
        for (j = 0; j<len; j++)
        {
            if (ans[j] == str[i][j])    tmp[j] = ans[j];
            else break;
        }
        tmp[j] = '\0';  //注意,不是tmp[++j]
        strcpy(ans, tmp);
    }
    reverse(ans);
    if (strlen(ans)) puts(ans);
    else    printf("nai\n");
    return 0;
}

收获

1.对于从后向前比较的字符串,先反转再操作的话会比较简单

//反转字符串
void reverse(char s[])
{
    int len = strlen(s);
    for (int i = 0; i<len / 2; i++)
    {
        int tmp = s[i];
        s[i] = s[len - 1 - i];
        s[len - 1 - i] = tmp;
    }
}

2.字符串注意处理最后的’\0’

        tmp[j] = '\0';  //注意,不是tmp[++j]
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值