HDU1072(BFS)Nightmare

Problem Description
Ignatius had a nightmare last night. He found himself in a labyrinth with a time bomb on him. The labyrinth has an exit, Ignatius should get out of the labyrinth before the bomb explodes. The initial exploding time of the bomb is set to 6 minutes. To prevent the bomb from exploding by shake, Ignatius had to move slowly, that is to move from one area to the nearest area(that is, if Ignatius stands on (x,y) now, he could only on (x+1,y), (x-1,y), (x,y+1), or (x,y-1) in the next minute) takes him 1 minute. Some area in the labyrinth contains a Bomb-Reset-Equipment. They could reset the exploding time to 6 minutes.

Given the layout of the labyrinth and Ignatius' start position, please tell Ignatius whether he could get out of the labyrinth, if he could, output the minimum time that he has to use to find the exit of the labyrinth, else output -1.

Here are some rules:
1. We can assume the labyrinth is a 2 array.
2. Each minute, Ignatius could only get to one of the nearest area, and he should not walk out of the border, of course he could not walk on a wall, too.
3. If Ignatius get to the exit when the exploding time turns to 0, he can't get out of the labyrinth.
4. If Ignatius get to the area which contains Bomb-Rest-Equipment when the exploding time turns to 0, he can't use the equipment to reset the bomb.
5. A Bomb-Reset-Equipment can be used as many times as you wish, if it is needed, Ignatius can get to any areas in the labyrinth as many times as you wish.
6. The time to reset the exploding time can be ignore, in other words, if Ignatius get to an area which contain Bomb-Rest-Equipment, and the exploding time is larger than 0, the exploding time would be reset to 6.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case starts with two integers N and M(1<=N,Mm=8) which indicate the size of the labyrinth. Then N lines follow, each line contains M integers. The array indicates the layout of the labyrinth.
There are five integers which indicate the different type of area in the labyrinth:
0: The area is a wall, Ignatius should not walk on it.
1: The area contains nothing, Ignatius can walk on it.
2: Ignatius' start position, Ignatius starts his escape from this position.
3: The exit of the labyrinth, Ignatius' target position.
4: The area contains a Bomb-Reset-Equipment, Ignatius can delay the exploding time by walking to these areas.
 

Output
For each test case, if Ignatius can get out of the labyrinth, you should output the minimum time he needs, else you should just output -1.
 

Sample Input
  
  
3 3 3 2 1 1 1 1 0 1 1 3 4 8 2 1 1 0 1 1 1 0 1 0 4 1 1 0 4 1 1 0 0 0 0 0 0 1 1 1 1 4 1 1 1 3 5 8 1 2 1 1 1 1 1 4 1 0 0 0 1 0 0 1 1 4 1 0 1 1 0 1 1 0 0 0 0 3 0 1 1 1 4 1 1 1 1 1
 

Sample Output
  
  
4 -1

13

//也就是走一步一分钟,总共六分钟限制 //当第六秒到达终点或者炸弹重置区时均无效 //也就是五步之内到达 //到达炸弹重置区时,还剩时间的话,倒计时将重置为6 //最快到达路径

找寻最短路,首先想到BFS,但是xy确定的某点不只可以走一次,因为走到xy的时间变量不同,所以vis数组建立为三位数组,将经过的点放入队列中去,取出某点时我们要调用的变量有x,y,和time,x和y对应的time是不固定的,所以z也要加到队列中去

#include <iostream>
#include <cstdio>
#include <fstream>
#include <string.h>
#include <queue>
using namespace std;

int si, sj, ei, ej;
int n, m;
int ma[9][9];
int dis[9][9];
int vis[9][9][9];
int dir[4][2] = {{0, 1}, {0, -1}, {-1, 0}, {1, 0}};

//也就是走一步一分钟,总共六分钟限制
//当第六秒到达终点或者炸弹重置区时均无效
//也就是五步之内到达
//到达炸弹重置区时,还剩时间的话,倒计时将重置为6
//最快到达路径

//可以重复到达某点
//但是相同时间到达该点多次走没有意义
//所以增加一个判断是否遍历过

//xy对应不同的tim
//所以也将tim存入队中

struct  Q{
    int hang;
    int lie;
    int time;
    Q(int hang, int lie, int time) : hang(hang), lie(lie), time(time) {}
};

int bfs()
{
    memset(vis, 0, sizeof(vis));
    queue<Q> que;
    que.push(Q(si, sj, 6));
    dis[si][sj] = 0;//距离
    vis[si][sj][6] = 1;
    while(que.size())
    {
        Q p = que.front();
        que.pop();
        for(int i = 0; i < 4; i++)
        {
            int x = p.hang + dir[i][0];
            int y = p.lie + dir[i][1];
            if(x >= 0 && x < n && y >= 0 && y < m && ma[x][y] != 0 && p.time > 1)
            {
                int tim;
                if(ma[x][y] == 4)
                    tim = 6;
                else
                    tim = p.time - 1;
                if(!vis[x][y][tim])
                {

                    vis[x][y][tim] = 1;
                    dis[x][y] = dis[p.hang][p.lie] + 1;
                    if(ma[x][y] == 3)
                        return dis[x][y];
                    que.push(Q(x, y, tim));
                }
            }
        }
    }
    return -1;
}
int main()
{
    //freopen("in.txt", "r", stdin);
    int t;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%d%d", &n, &m);
        for(int i = 0; i < n; i++)
        {
            for(int j = 0; j < m; j++)
            {
                scanf("%d", &ma[i][j]);
                if(ma[i][j] == 2)
                {
                    si = i;
                    sj = j;
                }
                else if(ma[i][j] == 3)
                {
                    ei = i;
                    ej = j;
                }
            }
        }
        printf("%d\n", bfs());
    }
    return 0;
}



 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值