poj 3641 Pseudoprime numbers

Pseudoprime numbers

Time Limit: 1000MS


Memory Limit: 65536K

Total Submissions: 8035


Accepted: 3341

Description

Fermat's theorem states that for any prime number p and for any integer a > 1, ap = a (mod p). That is, if we raise a to the pth power and divide by p, the remainder is a. Some (but not very many) non-prime values of p, known as base-pseudoprimes, have this property for some a. (And some, known as Carmichael Numbers, are base-a pseudoprimes for all a.)

Given 2 < p ≤ 1000000000 and 1 < a < p, determine whether or not p is a base-a pseudoprime.

Input

Input contains several test cases followed by a line containing "0 0". Each test case consists of a line containing p and a.

Output

For each test case, output "yes" if p is a base-a pseudoprime; otherwise output "no".

Sample Input

<span style="font-size:18px;">3 2
10 3
341 2
341 3
1105 2
1105 3
0 0
</span>

Sample Output

<span style="font-size:18px;">no
no
yes
no
yes
yes</span>

 题意:p不是素数,且a^p对p取模等于a,输出yes,其他的输出no。


题解:判断p是否是素数那部分直接蛮力求就好

代码:
#include<cstdio>
#include<cmath>
long long pow(long long a,long long p )
{
	long long ans=1,base=a,cnt=p;
	while(p>0)
	{
		if(p&1)
		  ans=(ans*base)%cnt;
		base=(base*base)%cnt;
		p>>=1;
	}
	return ans;
}
int prime(long long  n)//判断n是否是素数; 
{
	for(long long i=2;i*i<=n;i++)
	{
		if(n%i==0)
		  return 0;
	}
	return 1;
}
int main()
{
	long long p,a;
	while(scanf("%lld%lld",&p,&a)&&(p||a))
	{
		//printf("%d %d\n",pow(a,p),prime(p));
		if(pow(a,p)==a&&(!prime(p)))
		   printf("yes\n");
		else
		   printf("no\n");
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值