HDOJ 1010 Tempter of the Bone(剪枝+DFS)

Tempter of the Bone

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 106740    Accepted Submission(s): 29026


Problem Description
The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.
 

Input
The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

'X': a block of wall, which the doggie cannot enter;
'S': the start point of the doggie;
'D': the Door; or
'.': an empty block.

The input is terminated with three 0's. This test case is not to be processed.
 

Output
For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.
 

Sample Input
  
  
4 4 5 S.X. ..X. ..XD .... 3 4 5 S.X. ..X. ...D 0 0 0
 

Sample Output
  
  
NO YES
 


假设在某一时刻t,狗狗走到P(xi, yi),又记终点为D(x0, y0)。由P到D的路径可以分解为水平方向和竖直方向(类似于高中物理的位移的正交分解),就是说将P到D的每一条可行路径分解为从直线x = xi到达x = x0,和由直线y = yi到直线y = y0的两个分路径。现在考虑由x = xi到x = x0,当x0 - xi为偶数时,说明x0和xi的奇偶性相同,那么无论通过怎么样的路径由x = xi到x = x0,路径的步数总和必定为偶数(因为每走一步所处方位的x坐标奇偶性就变一次),不然不可能到达x0,,同理,当x0 - xi为奇数时,无论走什么路径,步数总和必为奇数。考查由xi到x0之后,yi到y0的情况不言而知。设由xi到x0的步数为tx,由yi到y0的步数为ty,则tx和ty的奇偶性分别与abs(xi - x0)和abs(yi - y0)的相同,所以总步数tx + ty的奇偶性和abs(xi - x0) + abs(yi - y0)的奇偶性相同。注意,总步数tx + ty实际上就是在P点时剩余的时间t。由此可知,由P到D的总步数,也就是剩余的时间t的奇偶性必定与abs(xi - x0) + abs(yi - y0)的奇偶性相同。不然就无法从P到达D。




分析:典型的迷宫搜索问题,使用的是DFS(深搜)。 还有涉及到剪枝问题,将不可能的先排除,不然会超时的这边的剪枝主要是奇偶性剪枝,就是如果最短路径的步数是偶数,要求的时间也要是偶数;如果是奇数,也要是奇数。。。然后对满足情况的进行深搜,当时间和位置都相符的时候就停止搜索,此时能找到出口。

代码:

#include<stdio.h>
#include<stdlib.h>
bool flag;
int n,m,t,i,j,x1,y1,x2,y2,num;
int dx[4]={0,0,-1,1};
int dy[4]={-1,1,0,0};  //设置四个方向,分别是左、右、下、上
char str[8][8];
void dfs(int k,int l,int tc)
{
    int i;
    if(tc==t && k==x2 &&l==y2)
       flag=true;
    if(flag) 
	   return;  
    if((abs(x2-k)+abs(y2-l))%2!=(t-tc)%2) 
	   return;   //奇偶性剪枝的判断条件
    for(i=0;i<4;i++)
    {
        int xx=k+dx[i];
        int yy=l+dy[i];
        if(xx>=0 && xx<n && yy>=0 && yy<m && str[xx][yy]!='X')
        {
            str[xx][yy]='X';
            dfs(xx,yy,tc+1);
            str[xx][yy]='.';    //此方向如果不行的话就回溯
        }
    }
}
int main()
{
    while (scanf("%d%d%d",&n,&m,&t))
    {
        if(n==0 && m==0 && t==0)
            break;
        num=0;
        flag=false;
        for(i=0;i<n;i++)
        {
        	scanf("%s",str[i]);
            for(j=0;j<m;j++)
            {
                if(str[i][j]=='S')
                {
                    x1=i;y1=j;
                }
                else if(str[i][j]=='D')
                {
                    x2=i;y2=j;
                    num++;
                }
                else if(str[i][j]=='.')
                {
                    num++;
                }
            }
        }
        str[x1][y1]='X';
        if(num>=t)
          dfs(x1,y1,0);
        if(flag) 
            printf("YES\n");
        else 
            printf("NO\n");
    }
    return 0;
}

 



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值