HDOJ 1856 More is better【并查集】(求一个集合中节点的总个数)

More is better

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 327680/102400 K (Java/Others)
Total Submission(s): 24339    Accepted Submission(s): 8736


Problem Description
Mr Wang wants some boys to help him with a project. Because the project is rather complex,the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.
 

Input
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)
 

Output
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.
 

Sample Input
  
  
4 1 2 3 4 5 6 1 6 4 1 2 3 4 5 6 7 8
 

Sample Output
  
  
4 2
Hint
A and B are friends(direct or indirect), B and C are friends(direct or indirect), then A and C are also friends(indirect). In the first sample {1,2,5,6} is the result. In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.
思路:本题不是求集合的个数,而是求每个集合中的元素个数,进而求所有集合中元素个数的最大值;需要在合并两个集合时处理一下,让这两个集合的元素个数也合并一下。
代码:
#include<stdio.h>
#include<math.h>
#include<string.h>
#include<algorithm>
using namespace std;
int pre[10000009];
int num[10000009];//num[i]表示以i节点为根节点的节点数,即一个集合中总的节点数;
int find(int x)//节点很多,路径压缩; 
{
	int r=x,t;
	while(pre[r]!=r)
	  r=pre[r];
	while(x!=r)
	{
		t=pre[x];
		pre[x]=r;
		x=t;
	}
	return r;
}
void merge(int x,int y)//合并a和b; 
{
	int fx=find(x);
	int fy=find(y);
	if(fx!=fy)
	{
		pre[fx]=fy;
		num[fy]+=num[fx];//合并集合中元素个数,把每个集合中元素个数存到每个集合根节点中; 
	}
}
int main()
{
	int n,i,j;
	while(scanf("%d",&n)!=EOF)
	{
		for(i=1;i<=10000000;i++)
		{
			pre[i]=i;
			num[i]=1;//刚开始每个集合只有一个点,初始都为1; 
		}
		int maxn=0;
		for(i=0;i<n;i++)
		{
			int u,v;
			scanf("%d%d",&u,&v);
			merge(u,v);
		}
		int MAX=1;
		for(int i=1;i<=10000000;i++)
		{
			if(num[i]>MAX)
			    MAX=num[i];
		}
		printf("%d\n",MAX);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值