POJ 2387 Til the Cows Come Home(Dijkstra,重边)

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible.

Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it.

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.
Input
* Line 1: Two integers: T and N
* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.
Output
* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.
Sample Input
5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100
Sample Output
90


直白的单源最短路径,直接Dijkstra。

记录这道题一是为了作为一个Dijkstra的基础模板保存下来,二是因为被重边的情况wa了一发,给自己长个记性。

重边就是说,从一个点到另一个点的直接路线可能不止一条。当输入数据中长度更大的边出现在后面时,悲剧就发生了…所以还是要考虑周全啊,真是防不胜防。

#include<cstdio>
#include<cstring>
#include<algorithm>
#define maxn 1005
int T,N;
int dis[maxn];
bool vis[maxn];
int maze[maxn][maxn];
int findmin(){
    int i,flag,mins;
    for(i=1;i<=N;i++){
        if(!vis[i]){
            flag=i;
            mins=dis[flag];
        }
    }
    for(i=1;i<=N;i++){
        if(!vis[i]&&dis[i]<mins){
            flag=i;
            mins=dis[i];
        }
    }
    return flag;
}
int ends(){
    int i;
    for(i=1;i<=N;i++){
        if(vis[i]==0){
            return 0;
        }
    }
    return 1;
}
using namespace std;
int main(){
    int i,j,k;
    int x,y,w,pics,mins;
    while(scanf("%d %d",&T,&N)!=EOF){
        memset(vis,0,sizeof(vis));
        memset(dis,10086,sizeof(dis));
        memset(maze,10086,sizeof(maze));
        for(i=1;i<=T;i++){
            scanf("%d %d %d",&x,&y,&w);
            if(w<maze[x][y]){//考虑到重边的情况
                maze[x][y]=w;
                maze[y][x]=w;
                if(x==N)
                    dis[y]=w;
                if(y==N)
                    dis[x]=w;
            }
        }
        vis[N]=1;
        dis[N]=0;
        for(i=1;i<=N;i++){
            pics=findmin();//寻找当前最短距离
            vis[pics]=1;
            for(j=1;j<N;j++){
                if((!vis[j])&&dis[j]>dis[pics]+maze[pics][j]){
                    dis[j]=dis[pics]+maze[pics][j];
                }
            }
            if(ends()){
                break;
            }
        }
        printf("%d\n",dis[1]);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值