ZOJ 3956 Course Selection System(01背包变形)

Course Selection System

Time Limit: 1 Second      Memory Limit: 65536 KB

There are n courses in the course selection system of Marjar University. The i-th course is described by two values: happiness Hi and credit Ci. If a student selects m courses x1, x2, ..., xm, then his comfort level of the semester can be defined as follows:

$$(\sum_{i=1}^{m} H_{x_i})^2-(\sum_{i=1}^{m} H_{x_i})\times(\sum_{i=1}^{m} C_{x_i})-(\sum_{i=1}^{m} C_{x_i})^2$$

Edward, a student in Marjar University, wants to select some courses (also he can select no courses, then his comfort level is 0) to maximize his comfort level. Can you help him?

Input

There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:

The first line contains a integer n (1 ≤ n ≤ 500) -- the number of cources.

Each of the next n lines contains two integers Hi and Ci (1 ≤ Hi ≤ 10000, 1 ≤ Ci ≤ 100).

It is guaranteed that the sum of all n does not exceed 5000.

We kindly remind you that this problem contains large I/O file, so it's recommended to use a faster I/O method. For example, you can use scanf/printf instead of cin/cout in C++.

Output

For each case, you should output one integer denoting the maximum comfort.

Sample Input
2
3
10 1
5 1
2 10
2
1 10
2 10
Sample Output
191
0
Hint

For the first case, Edward should select the first and second courses.

For the second case, Edward should select no courses.

【题意】每门课有一个H值和C值,学生选课的满意值=ΣH^2-ΣH*ΣC-ΣC^2。求学生选课的最大满意值。

【分析】满意值=ΣH(ΣH-ΣC)-ΣC^2,可见当C一定时,H越大,满意值越高。因此转化为C作为容量的01背包来求解。

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
#define maxn 505
int N,sum;
int h[maxn],c[maxn];
long long ans,dp[50005];
int main(){
    int T;
    scanf("%d",&T);
    while(T--){
        scanf("%d",&N);
        sum=0;ans=0;
        memset(dp,0,sizeof(dp));
        for(int i=0;i<N;i++){
            scanf("%d%d",&h[i],&c[i]);
            sum+=c[i];
        }
        for(int i=0;i<N;i++){
            for(int j=sum;j>=c[i];j--){
                if(dp[j]<=dp[j-c[i]]+h[i]){
                    dp[j]=dp[j-c[i]]+h[i];
                    ans=max(ans,dp[j]*dp[j]-dp[j]*j-j*j);
                }
            }
        }
        printf("%lld\n",ans);
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值