zoj3956 Course Selection System (背包)


Course Selection System

Time Limit: 1 Second       Memory Limit: 65536 KB

There are n courses in the course selection system of Marjar University. The i-th course is described by two values: happiness Hi and credit Ci. If a student selects m courses x1x2, ..., xm, then his comfort level of the semester can be defined as follows:

$$(\sum_{i=1}^{m} H_{x_i})^2-(\sum_{i=1}^{m} H_{x_i})\times(\sum_{i=1}^{m} C_{x_i})-(\sum_{i=1}^{m} C_{x_i})^2$$

Edward, a student in Marjar University, wants to select some courses (also he can select no courses, then his comfort level is 0) to maximize his comfort level. Can you help him?

Input

There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:

The first line contains a integer n (1 ≤ n ≤ 500) -- the number of cources.

Each of the next n lines contains two integers Hi and Ci (1 ≤ Hi ≤ 10000, 1 ≤ Ci ≤ 100).

It is guaranteed that the sum of all n does not exceed 5000.

We kindly remind you that this problem contains large I/O file, so it's recommended to use a faster I/O method. For example, you can use scanf/printf instead of cin/cout in C++.

Output

For each case, you should output one integer denoting the maximum comfort.

Sample Input
2
3
10 1
5 1
2 10
2
1 10
2 10
Sample Output
191
0
Hint

For the first case, Edward should select the first and second courses.

For the second case, Edward should select no courses.

题解:

做的时候没有发现数据范围可以弄成一个背包,还想着贪心去做,结果赛后才发现500*100完全可以开得下,这样一来就可以当做一个背包问题来做了,复杂度是O(MN),转移方程是q[j-cost[i]]=max(q[j-cost[i]],q[j]-h[i]);

代码如下:

#include <iostream>
#include <bits/stdc++.h>

using namespace std;

int q[50005];
int cost[505];
int h[505];

int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        memset(q,-1,sizeof(q));
        int n;
        int sum1=0;
        int sum2=0;
        cin>>n;
        for(int i=0;i<n;i++)
        {
            scanf("%d %d",&h[i],&cost[i]);
            sum1+=h[i];
            sum2+=cost[i];
        }
        q[sum2]=sum1;
        long long ans=-1;
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<=50000;j++)
            {
                if(q[j]==-1)
                    continue;
                q[j-cost[i]]=max(q[j-cost[i]],q[j]-h[i]);
            }
        }
        for(int i=0;i<50001;i++)
        {
            if(q[i]==-1)
                continue;
            ans=max(ans,(long long)q[i]*(long long)q[i]-(long long)i*(long long)q[i]-(long long)i*(long long)i);
        }
        cout<<ans<<endl;
    }
    //cout << "Hello world!" << endl;
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值