How Many Maos Does the Guanxi Worth

生气How Many Maos Does the Guanxi Worth

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)
Total Submission(s): 1725    Accepted Submission(s): 663


Problem Description
"Guanxi" is a very important word in Chinese. It kind of means "relationship" or "contact". Guanxi can be based on friendship, but also can be built on money. So Chinese often say "I don't have one mao (0.1 RMB) guanxi with you." or "The guanxi between them is naked money guanxi." It is said that the Chinese society is a guanxi society, so you can see guanxi plays a very important role in many things.

Here is an example. In many cities in China, the government prohibit the middle school entrance examinations in order to relief studying burden of primary school students. Because there is no clear and strict standard of entrance, someone may make their children enter good middle schools through guanxis. Boss Liu wants to send his kid to a middle school by guanxi this year. So he find out his guanxi net. Boss Liu's guanxi net consists of N people including Boss Liu and the schoolmaster. In this net, two persons who has a guanxi between them can help each other. Because Boss Liu is a big money(In Chinese English, A "big money" means one who has a lot of money) and has little friends, his guanxi net is a naked money guanxi net -- it means that if there is a guanxi between A and B and A helps B, A must get paid. Through his guanxi net, Boss Liu may ask A to help him, then A may ask B for help, and then B may ask C for help ...... If the request finally reaches the schoolmaster, Boss Liu's kid will be accepted by the middle school. Of course, all helpers including the schoolmaster are paid by Boss Liu.

You hate Boss Liu and you want to undermine Boss Liu's plan. All you can do is to persuade ONE person in Boss Liu's guanxi net to reject any request. This person can be any one, but can't be Boss Liu or the schoolmaster. If you can't make Boss Liu fail, you want Boss Liu to spend as much money as possible. You should figure out that after you have done your best, how much at least must Boss Liu spend to get what he wants. Please note that if you do nothing, Boss Liu will definitely succeed.
 

Input
There are several test cases.

For each test case:

The first line contains two integers N and M. N means that there are N people in Boss Liu's guanxi net. They are numbered from 1 to N. Boss Liu is No. 1 and the schoolmaster is No. N. M means that there are M guanxis in Boss Liu's guanxi net. (3 <=N <= 30, 3 <= M <= 1000)

Then M lines follow. Each line contains three integers A, B and C, meaning that there is a guanxi between A and B, and if A asks B or B asks A for help, the helper will be paid C RMB by Boss Liu.

The input ends with N = 0 and M = 0.

It's guaranteed that Boss Liu's request can reach the schoolmaster if you do not try to undermine his plan.
 

Output
For each test case, output the minimum money Boss Liu has to spend after you have done your best. If Boss Liu will fail to send his kid to the middle school, print "Inf" instead.
 

Sample Input
  
  
4 5 1 2 3 1 3 7 1 4 50 2 3 4 3 4 2 3 2 1 2 30 2 3 10 0 0
 

Sample Output
  
  
50 Inf
 

Source

这里可也把题意看成是最短路径问题,
又和最短路径不太一样,这里是要你去掉除一个1和N之外的点(2——n-1),再求最短路,找出最大的路径来,


#include<stdio.h>
#include <string.h>
#define inf 0x3f3f3f3f
using namespace std;
struct node
{
  int x;
  int y;
  int m;
} a[10002];
int e[350][350];
int dis[350];
int book[350];
int chazhao(int n,int m,int w)       //最短路   这里的m与n不是原来的意思了啊√
{
  int i,j,u = 1;
  for(i = 1; i <=  w; i++)
    {
      if(a[i].x == n||a[i].y == n)
        {
           e[a[i].x][a[i].y] = inf;         //这里需要注意了,害的我调了好长时间,要进行初始化,,,,
           e[a[i].y][a[i].x] = inf;
           continue;
        }
      if(e[a[i].x][a[i].y] > a[i].m)
        {
          e[a[i].x][a[i].y] = a[i].m;
          e[a[i].y][a[i].x] = a[i].m;
        }
    }
  /*  for(i = 1;i <= m ;i++)
    {
        for(j = 1;j <= m; j++)
        {
            printf("%d\t",e[i][j]);
        }
        printf("\n");
    }
    printf("\n");*/
  for(i = 1; i <= m; i++)
    {
      dis[i] = e[1][i];
    }
  for(i = 1; i <= m; i++)
    {
      book[i] = 0;
    }
  book[1] = 1;
  for(i = 1;i < m; i++)
  {
      int min = inf;
      for(j = 1;j <= m; j++)
      {
          if(book[j] == 0&&dis[j] < min)
          {
              min = dis[j];
              u = j;
          }
      }
      book[u] = 1;
      for(j = 1;j <= m; j++)
      {
          if(e[u][j] < inf)
          {
              if(dis[j] > dis[u]+e[u][j])
                  dis[j] = dis[u]+e[u][j];
          }
      }
  }
/*  for(i = 1;i <= m; i++)
  {
      printf("*%d* ",dis[i]);
  }
  printf("\n");*/
  return dis[m];
}
int main()
{
  int n,m,i,j;
  while(~scanf("%d %d",&n,&m))
    {
      if(n == 0&&m == 0) break;
      for(i = 1; i <= m; i++)                           //存储数据
        {
          scanf("%d %d %d",&a[i].x,&a[i].y,&a[i].m);
        }
      for(i = 1; i <= n; i++)                            //初始化
        {
          for(j = 1; j <= n; j++)
            {
              if(i == j)
                  e[i][j] = 0;
              else
              {
                  e[i][j] = inf;
              }
            }
        }
      int max1 = 0;
      int max; 
      for(i = 2; i < n; i++)                           //找出所有去除一个点后最短路的最大值
        {
          max = chazhao(i,n,m);
          if(max1 < max)
              max1 = max;
        }
        if(max1 >= inf)
        puts("Inf");                                    //不能是scanf(“Inf\n”);这样会报错,我调了好久不知道为什么?你知道吗?告诉我吧吐舌头
        else
        printf("%d\n",max1);
    }
    return 0;
}
代码菜鸟,如有错误,请多包涵!!
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值