杭电-5137-How Many Maos Does the Guanxi Worth

How Many Maos Does the Guanxi Worth

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)
Total Submission(s): 1666    Accepted Submission(s): 643


Problem Description
"Guanxi" is a very important word in Chinese. It kind of means "relationship" or "contact". Guanxi can be based on friendship, but also can be built on money. So Chinese often say "I don't have one mao (0.1 RMB) guanxi with you." or "The guanxi between them is naked money guanxi." It is said that the Chinese society is a guanxi society, so you can see guanxi plays a very important role in many things.

Here is an example. In many cities in China, the government prohibit the middle school entrance examinations in order to relief studying burden of primary school students. Because there is no clear and strict standard of entrance, someone may make their children enter good middle schools through guanxis. Boss Liu wants to send his kid to a middle school by guanxi this year. So he find out his guanxi net. Boss Liu's guanxi net consists of N people including Boss Liu and the schoolmaster. In this net, two persons who has a guanxi between them can help each other. Because Boss Liu is a big money(In Chinese English, A "big money" means one who has a lot of money) and has little friends, his guanxi net is a naked money guanxi net -- it means that if there is a guanxi between A and B and A helps B, A must get paid. Through his guanxi net, Boss Liu may ask A to help him, then A may ask B for help, and then B may ask C for help ...... If the request finally reaches the schoolmaster, Boss Liu's kid will be accepted by the middle school. Of course, all helpers including the schoolmaster are paid by Boss Liu.

You hate Boss Liu and you want to undermine Boss Liu's plan. All you can do is to persuade ONE person in Boss Liu's guanxi net to reject any request. This person can be any one, but can't be Boss Liu or the schoolmaster. If you can't make Boss Liu fail, you want Boss Liu to spend as much money as possible. You should figure out that after you have done your best, how much at least must Boss Liu spend to get what he wants. Please note that if you do nothing, Boss Liu will definitely succeed.
 

Input
There are several test cases.

For each test case:

The first line contains two integers N and M. N means that there are N people in Boss Liu's guanxi net. They are numbered from 1 to N. Boss Liu is No. 1 and the schoolmaster is No. N. M means that there are M guanxis in Boss Liu's guanxi net. (3 <=N <= 30, 3 <= M <= 1000)

Then M lines follow. Each line contains three integers A, B and C, meaning that there is a guanxi between A and B, and if A asks B or B asks A for help, the helper will be paid C RMB by Boss Liu.

The input ends with N = 0 and M = 0.

It's guaranteed that Boss Liu's request can reach the schoolmaster if you do not try to undermine his plan.
 

Output
For each test case, output the minimum money Boss Liu has to spend after you have done your best. If Boss Liu will fail to send his kid to the middle school, print "Inf" instead.
 

Sample Input
  
  
4 5 1 2 3 1 3 7 1 4 50 2 3 4 3 4 2 3 2 1 2 30 2 3 10 0 0
 

Sample Output
  
  
50 Inf
 

PS:题意是 Boss Liu想通过关系找到校长,让他儿子进入学校读书,而你讨厌Boss Liu,你想要阻止他,你只能说服他的关系网中的一个人不帮他,如果你说服一个人之后他不能通过关系找到校长,则输出Inf,如果可以,则输出Boss Liu需要花费多少钱,(你要让他花更多的钱)

输入n, m表示有n个人,m个关系

其中1为Boss Liu,n为校长

输入m个关系a b c,表示a能找b,b能找a,Boss Liu需要花c钱


这道题是求最短路的最大值,也就是Boss Liu想找最短最小值,你的任务是让这个最小值最大,或者让 他找不到校长


思路是每次尝试去掉一个人(当然这个人不能是Boss Liu也不能是校长),然后用dijkstra算法求单源最短路,如果去掉这个人后他找不到校长,则可以结束,输出Inf,否则如果该最小值大于之前保存的,则更新改值,具体看下代码:

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<string>
#include<algorithm>
#include<queue>
#include<math.h>
using namespace std;

int n, m;
long long map[35][35];
long long dis[35];
bool flag[35];
long long MAXD = 9999999999999999;

void dijkstra(int del)
{
	fill(dis, dis + 32, MAXD);
	fill(flag, flag + 32, false);
	flag[del] = true;
	dis[1] = 0;
	while (true)
	{
		int v = -1;
		for (int u = 1; u <= n; ++u)
		{
			if (!flag[u] && (v == -1 || dis[u] < dis[v]))
			{
				v = u;
			}
		}
		if (v == -1)
		{
			break;
		}
		flag[v] = true;
		for (int u = 2; u <= n; ++u)
		{
			dis[u] = min(dis[u], dis[v] + map[v][u]);
		}
	}
}

int main()
{
	while (cin >> n >> m && n && m)
	{
		for (int i = 0; i <= n; ++i)
		{
			fill(map[i], map[i] + 32, MAXD);
		}
		long long maxn = MAXD;
		for (int i = 1; i <= m; ++i)
		{
			int a, b, v;
			cin >> a >> b >> v;
			if (v < map[a][b])
			{
				map[a][b] = map[b][a] = v;
			}
		}
		long long ans = -1;
		for (int i = 2; i < n; ++i)
		{
			dijkstra(i);
			if (dis[n] != MAXD)
			{
				if (ans < dis[n])
				{
					ans = dis[n];
				}
			}
			else
			{
				ans = -1;
				break;
			}
		}
		if (ans == -1)
		{
			cout << "Inf" << endl;
		}
		else
		{
			cout << ans << endl;
		}
	}

	return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值