poj 3687 Labeling Balls

Labeling Balls
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 13578 Accepted: 3929

Description

Windy has N balls of distinct weights from 1 unit to N units. Now he tries to label them with 1 to N in such a way that:

  1. No two balls share the same label.
  2. The labeling satisfies several constrains like "The ball labeled with a is lighter than the one labeled with b".

Can you help windy to find a solution?

Input

The first line of input is the number of test case. The first line of each test case contains two integers, N (1 ≤ N ≤ 200) and M (0 ≤ M ≤ 40,000). The next M line each contain two integers a and b indicating the ball labeled with a must be lighter than the one labeled with b. (1 ≤ a, b ≤ N) There is a blank line before each test case.

Output

For each test case output on a single line the balls' weights from label 1 to label N. If several solutions exist, you should output the one with the smallest weight for label 1, then with the smallest weight for label 2, then with the smallest weight for label 3 and so on... If no solution exists, output -1 instead.

Sample Input

5

4 0

4 1
1 1

4 2
1 2
2 1

4 1
2 1

4 1
3 2

Sample Output

1 2 3 4
-1
-1
2 1 3 4
1 3 2 4

Source


这个题大意是
/*

给定几个标签球的重量大小关系,求每个球是第几重的(即每个球在所有球的重量中由小到大排名是多少)。

(输出是每个球第几重,而不是几号球比几号球重!)。

此题重点是:

1、需要逆序拓扑,找入读为零的点时要从大到小找。

2、注意最后的处理,是输出几号球是第几重的!!

     (重点) 例如:拓扑出的序列是1 4 2 3 5,就是4号球比1号球重,2号球比4号球重,输出序列是1 3 4 2 5,即1号球最轻,2号球第三轻……

*/

#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <stack>
#include <queue>
using namespace std;
int n,m;
int in[205];
vector<int> ve[205];
int s[205];
int cnt;
struct node
{
    int s1;
    int s2;
}a[20005];
queue<int> q;
int cmp(node q,node p)
{
    return q.s2 < p.s2;
}
void init()    //初始化
{
    int i;
    memset(in,0,sizeof(in));
    for(i = 1;i <= n; i++)
    {
        ve[i].clear();
    }
}
int fid(int x,int y)   //判断有没有重复输入
{
    int i;
    for(i = 0;i < ve[x].size();i++)
    {
        if(ve[x][i] == y)
            return 0;
    }
    return 1;
}
int topu()    //拓扑排序
{
    int i;
    while(!q.empty())
    {
        q.pop();
    }
    for(i = n;i > 0; i--)
    {
        if(in[i] == 0)
        {
            q.push(i);
            in[i] = -1;
            break;
        }
    }
    cnt = 0;
    while(!q.empty())
    {
        int t = q.front();
        s[cnt++] = t;
        q.pop();
        for(i = 0;i < ve[t].size();i++)
        {
            in[ve[t][i]]--;
        }
        for(i = n;i > 0; i--)
        {
            if(in[i] == 0)
            {
                q.push(i);
                in[i] = -1;
                break;
            }
        }
    }
    if(cnt < n)
        return 0;
    return 1;
}
int main()
{
    int i;
    int x,y;
    int t;
    scanf("%d",&t);
    while(t--)
    {
         scanf("%d %d",&n,&m);
        init();
        for(i = 0;i < m; i++)
        {
            scanf("%d %d",&x,&y);
            if(fid(y,x))
            {
                ve[y].push_back(x);
                in[x]++;
            }
        }
        if(topu())
        {
            for(i = 0;i < n; i++)    //重点内容
            {
                a[i].s1 = n-i;
                a[i].s2 = s[i];
            }
            sort(a,a+n,cmp);
            for(i = 0;i < n; i++)
            {
                printf(i != n-1?"%d ":"%d\n",a[i].s1);
            }
        }
        else
            printf("-1\n");
    }
}

代码菜鸟,如有错误,请多包涵!!


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值