poj----3259

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer,  FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively:  NM, and  W
Lines 2..  M+1 of each farm: Three space-separated numbers (  SET) that describe, respectively: a bidirectional path between  S and  E that requires  Tseconds to traverse. Two fields might be connected by more than one path. 
Lines  M+2..  MW+1 of each farm: Three space-separated numbers (  SET) that describe, respectively: A one way path from  S to  E that also moves the traveler back  T seconds.

Output

Lines 1..  F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES
#include <stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
#define MAXN 520
#define MAXM 6000

const int INF = (1<<26);

struct node
{
    int u, v, w;
} edge[MAXM];

int dis[MAXN], top;

int bellman_ford(int n)
{
    int i, j, u, v, w;

    for(i=1; i<=n; i++) 
        dis[i] = INF;
    
    dis[1] = 0;
    for(i=0; i<n-1; i++)
    {
        for(j=0; j<top; j++)
        {
            u = edge[j].u;
            v = edge[j].v;
            w = edge[j].w;
            if(dis[u] < INF && dis[u]+w < dis[v])
            {
                dis[v] = dis[u]+w;
            }
        }
    }
    for(j=0; j<top; j++)
    {
        u = edge[j].u;
        v = edge[j].v;
        w = edge[j].w;
        if(dis[u] < INF && dis[u]+w < dis[v])
        {
            return 0;
        }
    }
    return 1;
}

void add(int u, int v, int w)
{
    edge[top].u = u;
    edge[top].v = v;
    edge[top++].w = w;
}

int main()
{
    int T, n, m, l, i, u, v, w;

    scanf("%d", &T);
    while(T--)
    {
        top = 0;
        scanf("%d %d %d", &n, &m, &l);
        for(i=0; i<m; i++)
        {
            scanf("%d %d %d", &u, &v, &w);
            add(u, v, w);
            add(v, u, w);
        }
        for(i=0; i<l; i++)
        {
            scanf("%d %d %d", &u, &v, &w);
            add(u, v, -w);
        }
        if(!bellman_ford(n))
            printf("YES\n");
        else
            printf("NO\n");
    }

    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值