Number Sequence(KMP)

Number Sequence
Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 29708 Accepted Submission(s): 12504

Problem Description
Given two sequences of numbers : a[1], a[2], …… , a[N], and b[1], b[2], …… , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], …… , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.

Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], …… , a[N]. The third line contains M integers which indicate b[1], b[2], …… , b[M]. All integers are in the range of [-1000000, 1000000].

Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

Sample Input

2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1

Sample Output

6
-1

本题的题意就是查看b串是不是a串的子串 如果是的话返回最小的下标 如果不是的话返回-1 值得注意的是本题最好用scanf和printf进行输入输出 如果用cin和cout时间会超时

#include<iostream>
#include<string>
#include<string.h>


using namespace std;

int target[1000007], pattern[10007];
int nxt[10007];
int lens,lenp;
void Make_Next()
{
    int i = 0,j=-1;
    nxt[0] = -1;
    while(i!=lenp)
    {
        if(j==-1||pattern[i]==pattern[j])
            nxt[++i] = ++j;
        else
            j = nxt[j];
    }
}
int kmp()
{
    int i =0,j = 0;
    while(i!=lens&&j!=lenp)
    {
        if(j==-1||target[i]==pattern[j])
            i++,j++;
        else
            j = nxt[j];
         if(j>=lenp)
        {
            printf("%d\n",i-j+1);
            return 0;
        }
    }
   printf("-1\n");
    return 0;
}
int main()
{
    int ncase;
    cin>>ncase;
    while(ncase--)
    {
        scanf("%d%d",&lens,&lenp);
        for(int i = 0;i<lens;i++)
            scanf("%d",&target[i]);
        for(int j = 0;j<lenp;j++)
          scanf("%d",&pattern[j]);
        Make_Next();
        kmp();
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值