Count the string(KMP)

Count the string
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 11064 Accepted Submission(s): 5156

Problem Description
It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:
s: “abab”
The prefixes are: “a”, “ab”, “aba”, “abab”
For each prefix, we can count the times it matches in s. So we can see that prefix “a” matches twice, “ab” matches twice too, “aba” matches once, and “abab” matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For “abab”, it is 2 + 2 + 1 + 1 = 6.
The answer may be very large, so output the answer mod 10007.

Input
The first line is a single integer T, indicating the number of test cases.
For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.

Output
For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.

Sample Input

1
4
abab

Sample Output

6

#include<iostream>
#include<string>
#include<stdio.h>
#include<string.h>

using namespace std;

int nxt[200007],lenp;
char p[200007];
int dt[200007],sum;
void getNext()
{
    int i =0,j =-1;
    nxt[0] = -1;
    while(i<lenp)
    {
        if(j==-1||p[i]==p[j])
            nxt[++i] =++j;
        else
            j = nxt[j];
    }
}
void kmp()
{
    int i =0;
    memset(dt,0,sizeof(dt));
    sum = 0;
    //dt数组的意义是统计以i结尾的前缀出现的次数
    //而nxt数组存储的就是最大前后缀的长度
    //所以dt[i] = dt[nxt[i]] +1 意思就是第i位的次数 就是dt[nxt[i]] + 本身
    //举个例子 aba 以a结尾前缀的有 a aba 这两种 所以dt[3] = 2 ababa 以a为结尾前缀的有a aba ababa 这三种 dt[5] =3;
    for(int i =1;i<=lenp;i++)
    {
        dt[i] = dt[nxt[i]] +1;
        sum = (sum + dt[i])%10007;
    }
}
int main()
{
    int ncase;
    scanf("%d",&ncase);
    while(ncase--)
    {
        scanf("%d",&lenp);
        scanf("%s",p);
        getNext();
        kmp();
        printf("%d\n",sum);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值