HDU4278 Faulty Odometer

Description

  You are given a car  odometer (里程表) which displays the miles traveled as an  integer (整数). The odometer has a  defect (缺点), however: it  proceeds (收入) from the  digit (数字) 2 to the digit 4 and from the digit 7 to the digit 9, always skipping over the digit 3 and 8. This defect shows up in all positions (the one's, the ten's, the hundred's, etc.). For example, if the odometer displays 15229 and the car travels one mile, odometer reading changes to 15240 (instead of 15230). 

Input

  Each line of  input (投入) contains a  positive (积极的) integer in the range 1..999999999 which represents an odometer reading. (Leading zeros will not appear in the input.) The end of input is  indicated (表明) by a line containing a single 0. You may  assume (承担)that no odometer reading will contain the digit 3 and 8. 

Output

  Each line of input will produce exactly one line of  output (输出), which will contain: the odometer reading from the input, a colon, one blank space, and the actual number of miles traveled by the car. 

Sample Input

15
2005
250
1500
999999
0

Sample Output

15: 12
2005: 1028
250: 160
1500: 768
999999: 262143

这题我做完之后上网搜了一下,发现都是说是由八进制转化为十进制,想了一下,确实是这么回事,然而对我这个各种进制全凭自学的人来说,想转化成代码可不容易,而我自己的想法,就是利用dp找每一位所能包含的不含3,8的数的个数,然后一位位加过去就行。

#include <stdio.h>
#include <cstring>

int dp[15],v[15],l;

void init()
{
	int i;
	dp[0]=1;
	for(i=1;i<10;i++)
	{
		dp[i]=dp[i-1]*8;
	}
}

int main()
{
	int i,j;
	int n;
	init();
	while(~scanf("%d",&n)&&n)
	{
		int ans=0;
		l=0;
		int no=n;
		while(n)
		{
			v[l++]=n%10;
			n=n/10;
		}
		for(i=l-1;i>=0;i--)
		{
			if(v[i]>3&&v[i]<8)
				v[i]--;
			else if(v[i]>8)
				v[i]=v[i]-2;
			ans+=dp[i]*v[i];
		}
		printf("%d: %d\n",no,ans);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值