POJ 2299 Ultra-QuickSort 树状数组

Description

In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence 
9 1 0 5 4 ,

Ultra-QuickSort produces the output 
0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6
0

这题要知道最少所需的交换次数就是从后往前开始看,看后面的数有几个比自己小,加上去,再依次往前,就是结果了。

主要用到的技巧除了树状数组就是离散化,因为我们注意到500000个数的范围会达到999999999,太大了,所以我们可以利用结构体标记他们的大小关系,利用结构体来记录他们的大小关系,这样就可以节省很多空间。

#include <stdio.h>
#include <string.h>
#include<algorithm>
using namespace std;

struct node
{
	int val;
	int pos;
}num[500000+10];

int cmp(node x,node y)
{
	return x.val<y.val;
}

int cmp1(node x,node y)
{
	return x.pos<y.pos;
}

const int n=500000+10;
__int64 c[n];
int lowbit(int k)  
{  
    return (k&(-k));  
}

__int64 sum(int x)  		//求和
{  
    __int64 ret = 0;  
    while(x>0)  
    {  
        ret+=c[x];  
        x-=lowbit(x);  
    }  
    return ret;  
}  

void add(int x,int d)  		//修改节点的值
{  
    while(x<=n)  
    {  
        c[x]+=d;  
        x+=lowbit(x);  
    }  
}

int main()
{
	int t;
	while(~scanf("%d",&t)&&t)
	{
		int i;
		__int64 ans=0;
		memset(c,0,sizeof(c));
		for(i=0;i<t;i++)
		{
			scanf("%d",&num[i].val);
			num[i].pos=i;
		}
		sort(num,num+t,cmp);
		for(i=0;i<t;i++)
		{
			num[i].val=i+1;
		}
		sort(num,num+t,cmp1);
		for(i=t-1;i>=0;i--)
		{
			add(num[i].val,1);
			ans+=sum(num[i].val-1);
		}
		printf("%I64d\n",ans);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值