HDU - 2199

Can you solve this equation?

Description

Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.

Input

The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);

Output

For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.

Sample Input

2
100
-4

Sample Output

1.6152
No solution!


题目大意:
没什么好多说的了,就是求解 方程y=8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 。对于给定的y值在0~100的范围内求x的近似解。

解题思路:
利用二分查找的方式搜索x的近似解,这里注意到函数是单调递增的,可以利用这个性质快速搜索。另外在计算Y值的时候,可以用y = (((x*x+7)*x+2)*x+3)*x+6的方法。

注意: 题目中要求精确到小数点后4位,也就要求的近似解的第5位小数必须是精确的!(不然会WrongAnswer…)


源代码:

#include<iostream>
#include<stdio.h>
#include<vector>
#include<algorithm>
#include<sstream>
using namespace std;


bool test(double x, double y) {
    double temp = (double)8 * x + 7.0;
    temp = temp*x + 2.0;
    temp = temp*x + 3.0;
    temp = temp*x + 6.0;
    return (temp - y)>0;
}

double binary_search(double y) {
    double l = 0, h = 100;
    double m;
    while (h-l>0.000001) {            //近似的精度
        m = (h + l) / 2.0;
        if (test(m, y))
            h = m;
        else
            l = m;
    }
    return m;
}

int main() {
    int times;
    double num;
    scanf("%d", &times);
    for (int ti = 0; ti < times; ti++) {
        scanf("%lf", &num);
        if (num < 6 || num >807020306)      //在0~100的范围内求解
            printf("No solution!\n");
        else
            printf("%.4lf\n", binary_search(num));
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值