HDU-2199 二分查找

/*给出方程:
       8*x4 + 7*x3 + 2*x2 + 3*x + 6 = Y
其中,实数Y满足 (fabs(Y) <= 1e10)


请输出x在区间[0,100]的解,结果精确到小数点后4位。


  当数很大的时候用暴力枚举就不适合,所以采用二分查找
*/

Problem Description

Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.


Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);


Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.


Sample Input
2
100
-4


Sample Output
1.6152

No solution!

代码实现:

#include <iostream>
#include <cmath>
using namespace std;
double Y;
double l, r, m;
double f( double x )
{    return 8*pow(x, 4.0) + 7*pow(x, 3.0) + 2*pow(x, 2.0) + 3*x + 6;}
int main() {
    int t;
    scanf("%d", &t );
    while( t-- ) {
        scanf("%lf", &Y );
        if( f(0) <= Y && Y <= f(100) ) {
            l = 0;
            r = 100;
            while( r - l > 1e-6 ) {
                m = (l + r) / 2;  //折半
                double ans = f(m);
                if( ans > Y ) {
                    r = m - 1e-7;
                }else
                    l = m + 1e-7;
            }
            printf("%.4lf\n", (l + r) / 2 );
        }else
            printf("No solution!\n");
    }
	return 0;
}


  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值