nyoj129 树的判定

树的判定
时间限制:1000 ms  |  内存限制:65535 KB
难度:4

描述

    A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.

    There is exactly one node, called the root, to which no directed edges point.
    Every node except the root has exactly one edge pointing to it.
    There is a unique sequence of directed edges from the root to each node.

    For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.


    In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

输入
    The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.

    The number of test cases will not more than 20,and the number of the node will not exceed 10000.
    The inputs will be ended by a pair of -1.
输出
    For each test case display the line "Case k is a tree." or the line "Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).
样例输入

    6 8  5 3  5 2  6 4 5 6  0 0

    8 1  7 3  6 2  8 9  7 5 7 4  7 8  7 6  0 0

    3 8  6 8  6 4 5 3  5 6  5 2  0 0
    -1 -1

样例输出

    Case 1 is a tree.
    Case 2 is a tree.
    Case 3 is not a tree.



// ac

#include <stdio.h>


typedef struct Tree {
    int num;// 父节点的个数
    int p;// 记录父节点
    bool h;// 表示已经遍历
    bool j;
    Tree() {
        num = 0;
        p = -1;
        h = 0;
        j = 0;
    }
    void goZero() {
        num = 0;
        p = -1;
        h = 0;
        j = 0;
    }
}Tree;

Tree tree[20100];

/**
 * (1)空树是一颗树
 * (2)每个结点只有唯一父节点
 * (3)一颗树只有一个根节点
 */
int main() {
    int a, b, i, j, k, root, temp, flag = 0;

    for(i = 1,k = 0,root = 0;scanf("%d%d", &a, &b) != EOF && (a != -1 || b != -1);++k) {
        if(a == 0 && b == 0) {
            // flag = 0,表示入度为1,现在判断是否存在环
            if(flag == 0) {
                // 只要存在一个环,就结束
                for(j = 0;j <= 20010;++j) {
                    // 表示没走过
                    if(tree[j].h == 0 && tree[j].p != -1) {
                        temp = j;
                        while(1) {
                            temp = tree[temp].p;
                            // 构成环
                            if((temp == j && temp != -1)) {
                                flag = 1;j = k + 1;
                                break;
                            } else if(tree[temp].p == -1) {
                                break;
                            }
                            // 表示走过这一点,根节点不标记
                            if(tree[temp].p != -1)
                                tree[temp].h = 1;
                        }
                    }
                    // 遍历多少个根
                    if(tree[j].j == 1 && tree[j].p == -1) {
                        ++root;
                        // 超过1个根,结束
                        if(root > 1)
                            break;
                    }
                }
            }
            // 不是一颗树
            if(flag == 1 || root > 1) {
                printf("Case %d is not a tree.\n", i);
            }
            // 是一颗树
            else {
                printf("Case %d is a tree.\n", i);
            }
            ++i;
            for(j = 0;j <= 20010;++j) {
                if(tree[j].j == 1)
                    tree[j].goZero();
            }
            root = flag = k = 0;
        } else if(a == b) {
            flag = 1;
        } else if(a < 0 || b < 0){
            flag = 1;
        } else if(flag == 0) {
            // 注意重复节点,也要考虑
            tree[b].p = a;
            ++tree[b].num;
            tree[a].j = 1;
            tree[b].j = 1;
            if(tree[b].num > 1)
                flag = 1;
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值