NYOJ129(判定树)

树的判定

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 4
描述

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties. 

There is exactly one node, called the root, to which no directed edges point. 
Every node except the root has exactly one edge pointing to it. 
There is a unique sequence of directed edges from the root to each node. 

For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not. 


In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

输入
The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.

The number of test cases will not more than 20,and the number of the node will not exceed 10000.
The inputs will be ended by a pair of -1.
输出
For each test case display the line "Case k is a tree." or the line "Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).
样例输入
6 8  5 3  5 2  6 4 5 6  0 0

8 1  7 3  6 2  8 9  7 5 7 4  7 8  7 6  0 0

3 8  6 8  6 4 5 3  5 6  5 2  0 0
-1 -1
样例输出
Case 1 is a tree.
Case 2 is a tree.

Case 3 is not a tree.

//题目大意:判断一个有向图是否为树
//构成树的条件:
//(1) 每个结点的入度为1,(2) 只有一个称为根的结点。(3)空树也是一棵树。
//定义三个数组 per[],vis[],num[];
//per[]:用来存放某个结点的根结点,
//vis[]:标记在树中结点,如果该节点i在该树中,vis[i]=1,方便后面统计树中根节点的数目 。
//num[]: 统计某结点i的入度 
#include<stdio.h>
#include<string.h> 
int per[100010],vis[100010],num[10010];
                                     
int max(int x,int y)               
{
	return x>y?x:y;
}
void init()                        //初始化 
{
	memset(vis,0,sizeof(vis));
	memset(num,0,sizeof(num));
	for(int i=0;i<=10010;i++)
	 per[i]=i;
}
int find(int x)           //找寻根结点 
{
	int r=x;
	while(r!=per[r])
	 r=per[r];
	return r;
}
bool join(int x,int y)        //合并两个子树 
{
	int fx=find(x),fy=find(y);
	if(fx!=fy)
	{
		per[fy]=fx;
		return true;
	}
	return false;
}
int main()
{
   int a,b,i,k,flag=1,maxl=0,ca=1;
   init();
   while(scanf("%d%d",&a,&b)==2)
   {
      if(a==b&&b==-1) break;
      if(a!=0&&b!=0)
      {
      	k=join(a,b);
      	if(k==0) flag=0;              //存在环,flag=0. 
      	if(!vis[a]) vis[a]=1;
		if(!vis[b]) vis[b]=1; 
		num[b]++;    
		if(num[b]>1) flag=0;         //入度大于1,flag=0; 
		maxl=max(maxl,max(a,b));
	  }
	  else
	  {
	  	int cnt=0,f;
	  	for(i=0;i<=maxl;i++)
	  	{
	  	  if(vis[i]&&i==find(i))
		   cnt++;	
		}
		if(cnt>1) flag=0;            //图中根结点个数大于1,flag=0; 
		if(flag==0) printf("Case %d is not a tree.\n",ca++);
		else        printf("Case %d is a tree.\n",ca++);
		flag=1;
		init();
	  }
   }	
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

bokzmm

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值