NYOJ 129 树的判定 (并查集)


树的判定

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 4
描述

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties. 

There is exactly one node, called the root, to which no directed edges point. 
Every node except the root has exactly one edge pointing to it. 
There is a unique sequence of directed edges from the root to each node. 

For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not. 


In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

输入
The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.

The number of test cases will not more than 20,and the number of the node will not exceed 10000.
The inputs will be ended by a pair of -1.
输出
For each test case display the line "Case k is a tree." or the line "Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).
样例输入
6 8  5 3  5 2  6 4 5 6  0 0

8 1  7 3  6 2  8 9  7 5 7 4  7 8  7 6  0 0

3 8  6 8  6 4 5 3  5 6  5 2  0 0
-1 -1
样例输出
Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.
题意:判断一个有向图是否是树。
分析:如果一个图是树,那么必须满足以下情况: 
1、树的数量不能大于1,空树也是树;
2、节点入度数不能大于1;
3、不能成环,比如一棵树的叶子节点指向根节点就是非法的;

4、自环是非法的。

#include <iostream>
#include <cstring>
using namespace std;
int pre[10010], v[10010];

int find(int x)
{
    if (pre[x] == -1)
        return x;
    else
        return find(pre[x]);
}

int main()
{
    int a, b, cas = 0;
    while (cin >> a >> b){
        if (a == -1 && b == -1)
            break;
        int k, flag, sum;
        if (a == 0 && b == 0){
            cout << "Case " << ++cas << " is a tree." << endl;
            continue;
        }
        memset(v, 0, sizeof(v));
        memset(pre, -1, sizeof(pre));
        k = flag = 0;
        sum = 1;
        if (a == b)
            flag = 1;
        else{
            v[a] = v[b] = 1;
            k += 2;
        }
        pre[b] = a;
        while (cin >> a >> b, a + b){
            int fx, fy;
            if (flag)
                continue;
            if (!v[a]){
                v[a] = 1;
                k++;
            }
            if (!v[b]){
                v[b] = 1;
                k++;
            }
            if (a == b){
                flag = 1;
                continue;
            }
            fx = find(a);
            fy = find(b);
            if (fx == fy || fy != b){    //注意,fy!=b。b此时已经有父亲节点此时又有一个节点指向了b,也就是树中不存在入度大于一的节点   
                flag = 1;
                continue;
            }
            pre[fy] = fx;
            sum++;
        }
        if (flag || k != sum + 1)
            cout << "Case " << ++cas << " is not a tree." << endl;
        else
            cout << "Case " << ++cas << " is a tree." << endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值