Oulipo KMP

Oulipo
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 39658 Accepted: 15959
Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with |W| ≤ |T| ≤ 1,000,000.
Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN
Sample Output

1
3
0
Source

BAPC 2006 Qualification

#include<stdio.h>
#include<string.h>

char x[1000050];
char y[1000050];
int next[1000050];
int n,m;
/*
void get_next()
{

    int i, j;
    next[0] = -1;
    j=-1;
    i = 0;
    while (i < m)
    {

        while (j != -1 && x[i] != x[j])
            j = next[j];

        next[++i] = ++j;
    }
}
*/
void get_next()
{
    int i,j;
    next[0]=-1;
    i=0;
    j=-1;
    while(i<m)
    {

        while(-1!=j&&x[i]!=x[j])
            j=next[j];
        if(x[++i]==x[++j])
            next[i]=next[j];
        else next[i]=j;
    }

}
int kmp()
{
    int i,j;
    int ans=0;
    i=j=0;
    while(i<n)
    {
        while(-1!=j&&y[i]!=x[j])
            j=next[j];
        i++;j++;
        if(j>=m)
        {

            ans++;
            j=next[j];
            //j=0;
        }
    }
    return ans;
}
int main()
{
    int num;
    scanf("%d", &num);
    while(num--)
    {
    scanf("%s", x);

    scanf("%s", y);
    n = strlen(y);
    m = strlen(x);
    get_next();
    int ans=kmp();
    printf("%d\n",ans);
    }

}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值