UVA 11059 Maximum Product

Given a sequence of integers S = {S1, S2, . . . , Sn}, you should determine what is the value of the maximum positive product involving consecutive terms of S. If you cannot find a positive sequence,you should consider 0 as the value of the maximum product.

Input

Each test case starts with 1 ≤ N ≤ 18, the number of elements in a sequence. Each element Siisan integer such that −10 ≤ Si ≤ 10. Next line will have N integers, representing the value of eachelement in the sequence. There is a blank line after each test case. The input is terminated by end offile (EOF).

Output

For each test case you must print the message: ‘Case #M: The maximum product is P.’, where M is the number of the test case, starting from 1, and P is the value of the maximum product. After each test case you must print a blank line.

Sample Input

3

2 4 -3

5

2 5 -1 2 -1


Sample Output

Case #1: The maximum product is 8.

Case #2: The maximum product is 20.

UVA的格式是真的牛掰!

看我加粗的两行。

一开始我以为是输入完以后输出一个空行。

在输出数据后再输出一个空行。

结果是只要后面那个,QAQ!

不多说,来说思路:

求连续子串的积,我们可以找到起点和终点即可,又因为每个元素的绝对值不超过10且只有18个元素,最大枚举数不超过10的18次方,我们可以用 long long存储即可。

#include<iostream>
#include<cstdio>
using namespace std;

int main() 
{
	int n;
	int T=0;
	while(scanf("%d",&n)!=EOF)
	{
		int a[20];
		long long max=0,sum=1;
		
		for(int i=0;i<n;i++)
		{
			cin>>a[i];
		}
		//if(T++) cout<<"\n";
		T++;
		for(int i=0;i<n;i++)
		{
		  for(int j=i;j<n;j++)
		  {
		  	sum*=a[j];
		  	if(sum>max)
		  	  max=sum;
		  }
		  sum=1;
		}
		  
		if(max<=0)
		{
		   printf("Case #%d: The maximum product is %ld.\n\n",T,0);	
		}
		  
		else
		{
		   printf("Case #%d: The maximum product is %ld.\n\n",T,max);
		}
		      
		
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值