hdu 1227 Fast Food

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1227

题目描述:

 

Description

The fastfood chain McBurger owns several restaurants along a highway. Recently, they have decided to build several depots along the highway, each one located at a restaurant and supplying several of the restaurants with the needed ingredients. Naturally, these depots should be placed so that the average distance between a restaurant and its assigned depot is minimized. You are to write a program that computes the optimal positions and assignments of the depots. 

To make this more precise, the management of McBurger has issued the following specification: You will be given the positions of n restaurants along the highway as n integers d1 < d2 < ... < dn (these are the distances measured from the company's headquarter, which happens to be at the same highway). Furthermore, a number k (k <= n) will be given, the number of depots to be built. 

The k depots will be built at the locations of k different restaurants. Each restaurant will be assigned to the closest depot, from which it will then receive its supplies. To minimize shipping costs, the total distance sum, defined as 



must be as small as possible. 

Write a program that computes the positions of the k depots, such that the total distance sum is minimized. 

Input

The input file contains several descriptions of fastfood chains. Each description starts with a line containing the two integers n and k. n and k will satisfy 1 <= n <= 200, 1 <= k <= 30, k <= n. Following this will n lines containing one integer each, giving the positions di of the restaurants, ordered increasingly. 

The input file will end with a case starting with n = k = 0. This case should not be processed. 

Output

For each chain, first output the number of the chain. Then output a line containing the total distance sum. 

Output a blank line after each test case. 

Sample Input

6 3
5
6
12
19
20
27
0 0

Sample Output

Chain 1
Total distance sum = 8

 

题目大意:

 

第一行输入两个整数m,n,代表有m个商店,要在这m个商店中选出n个做仓库,规定每个商店都去离他最近的仓库进货,问,建好仓库以后所有商店进货距离加起来的最小值是多少

 

题目分析:

这里我们需要知道在i到j取一点使它到区间每一点的距离之和最小,这一点为(i+j)/2用图形即可证明;

dp[i][j]代表在前j个商店建i个仓库,总距离最小值。dir[i][j]代表在商店i~j之间建一个仓库,增加的距离

 

AC代码:

 

#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;

int map[1005];
int dp[1005][1005],dir[1005][1005];//dp[i][j]代表在前j个商店建i个仓库,总距离最小值
int m,n;

int main()
{
    int num=1;
    while(1)
    {
        cin>>m>>n;//m个商店,n个仓库
        if(m==0&&n==0)
            break;
        memset(dir,0,sizeof(dir));
        for(int i=1;i<=m;i++)
            cin>>map[i];
        for(int i=1;i<=m;i++)
        {
            for(int j=i;j<=m;j++)
            {
                for(int k=i;k<=j;k++)
                {
                    dir[i][j]+=fabs(map[k]-map[(i+j)/2]);//dir[i][j]代表在商店i~j之间建一个仓库,增加的距离
                }
            }
        }
        
        for(int i=1;i<=m;i++)
            {
                dp[1][i]=dir[1][i];
            }
        for(int i=2;i<=n;i++)
        {
            for(int j=i;j<=m;j++)
            {
                dp[i][j]=0xfffffff;
                for(int k=i-1;k<=j-1;k++)
                    {
                        dp[i][j]=min(dp[i][j],dp[i-1][k]+dir[k+1][j]);
                    }
            }
        }
        cout<<"Chain "<<num++<<endl<<"Total distance sum = "<<dp[n][m]<<endl<<endl;
    }
    return 0;
}

 

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值