ZOJ - 1649 Rescue

题目:

 

Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)

 

Input

 

First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend.

Process to the end of the file.

 

Output

 

For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life."

 

Sample Input

 

7 8 
#.#####. 
#.a#..r. 
#..#x... 
..#..#.# 
#...##.. 
.#...... 
........

 

Sample Output

 

13

 

 

 

题目大意:

寻找从r到a的最短时间的通路,其中通过点x需要2s

题目分析:

最优解用bfs,具体求解思路详见代码注释:

AC代码:

 

#include<iostream>
#include<cstring>
#include<cstdlib>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<queue>
using namespace std;
const int maxn=205;
const int INF=0xfffffff;
char map[maxn][maxn];
int mintime[maxn][maxn];//记录到达(x,y)的最短时间
int sx,sy,ex,ey;
int dx[]={0,0,-1,1};
int dy[]={1,-1,0,0};
struct p
{
    int x,y;
    int time;//到达(x,y)所需要的时间
};
int n,m;
queue<p> Q;
int bfs(p s)
{
    Q.push(s);
    p push_p;//记录队首元素
    while(!Q.empty())
    {
        push_p=Q.front();
        Q.pop();
        for(int i=0;i<4;i++)
        {
            int x=push_p.x+dx[i],y=push_p.y+dy[i];
            if(x>=0&&x<n&&y>=0&&y<m&&map[x][y]!='#')
            {
                p now;//向该方向移动了一步到达的位置
                now.x=x;
                now.y=y;
                now.time=push_p.time+1;
                if(map[x][y]=='x')
                    now.time++;
                if(now.time<mintime[x][y])
                {
                    mintime[x][y]=now.time;
                    Q.push(now);
                }
            }
        }
    }
    return mintime[ex][ey];
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        for(int i=0;i<n;i++)
        {
            scanf("%s",map[i]);
            for(int j=0;j<m;j++)
            {
                if(map[i][j]=='r')
                {
                    sx=i;
                    sy=j;
                }
                else if(map[i][j]=='a')
                {
                    ex=i;
                    ey=j;
                }
                mintime[i][j]=INF;
            }
        }
        p start;
        start.x=sx;
        start.y=sy;
        start.time=0;
        mintime[sx][sy]=0;
        int t=bfs(start);
        if(t<INF)
            cout<<t<<endl;
        else
            cout<<"Poor ANGEL has to stay in the prison all his life."<<endl;
    }
    return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip 【备注】 1、该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的,请放心下载使用!有问题请及时沟通交流。 2、适用人群:计算机相关专业(如计科、信息安全、数据科学与大数据技术、人工智能、通信、物联网、自动化、电子信息等)在校学生、专业老师或者企业员工下载使用。 3、用途:项目具有较高的学习借鉴价值,不仅适用于小白学习入门进阶。也可作为毕设项目、课程设计、大作业、初期项目立项演示等。 4、如果基础还行,或热爱钻研,亦可在此项目代码基础上进行修改添加,实现其他不同功能。 欢迎下载!欢迎交流学习!不清楚的可以私信问我! 毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值