Rescue (ZOJ - 1649 )

Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)

Input

First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend.

Process to the end of the file.

Output

For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life."

Sample Input

7 8 
#.#####. 
#.a#..r. 
#..#x... 
..#..#.# 
#...##.. 
.#...... 
........

Sample Output

13

题解:天使(a)被困于迷宫,它的朋友(r)去救她,在迷宫中会有守卫(x)。r每走一步耗费一个单位的时间,如果路途遇上x,杀死x则需要一个单位的时间,求r找到a的最短时间。此题是一个迷宫问题,求解最短路径。使用广度优先搜索可解。

代码如下:

#include <iostream>
#include <cstdio>
#include <stdlib.h>
#include <cmath>
#include <cstring>
#include <algorithm>
#include <string.h>
#include <vector>
#include <queue>
#include <stack>
#include <set>
#include <map>
#include <ctime>
#define maxn 1007
#define N 100005
#define INF 0x3f3f3f3f
#define PI acos(-1)
#define lowbit(x) (x&(-x))
#define eps 0.000000001
#define read(x) scanf("%d",&x)
#define put(x) printf("%d\n",x)
#define Debug(x) cout<<x<<" "<<endl
using namespace std;
typedef long long ll;

const int direction[4][2]={{-1,0},{1,0},{0,-1},{0,1} };//四个方向
int row,col;//行、列
int startR,startC;//起始点行列
char maze[200][201];//迷宫
bool visit[200][201];//标记

int bfs()
{
    queue<int>open;
    open.push(startR);
    open.push(startC);
    open.push(0);
    visit[startR][startC]=true;
    while(!open.empty())
    {
        int r=open.front();
        open.pop();
        int c=open.front();
        open.pop();
        int t=open.front();
        open.pop();
        if(maze[r][c]=='a')
        {
            return t;
        }
        else if(maze[r][c]=='x')
        {
            maze[r][c]='.';
            open.push(r);
            open.push(c);
            open.push(t+1);
            continue;
        }
        for(int d=0; d<4; ++d)
        {
            int dr=r+direction[d][0];
            int dc=c+direction[d][1];
            if(dr>=0 && dr<row && dc>=0 && dc<col&&maze[dr][dc]!='#' && !visit[dr][dc])
            {
                visit[dr][dc]=true;
                open.push(dr);
                open.push(dc);
                open.push(t+1);
            }
        }
    }
    return -1;
}

int main()
{
    while(scanf("%d%d",&row,&col)!=EOF)
    {
        for(int i=0; i<row; ++i)
        {
            scanf("%s",maze[i]);
            for(int k=0; k<col; ++k)
            {
                if(maze[i][k]=='r')
                {
                    startR=i;
                    startC=k;
                }
                visit[i][k]=false;
            }
        }
        int t=bfs();
        if(t==-1)
            printf("Poor ANGEL has to stay in the prison all his life.\n");
        else
            printf("%d\n",t);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值