PAT甲1069/乙1019:The Black Hole of Numbers/数字黑洞

Problem Discription:

For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174 -- the black hole of 4-digit numbers. This number is named Kaprekar Constant.

For example, start from 6767, we'll get:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
... ...

Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range (0,10​4​​).

Output Specification:

If all the 4 digits of N are the same, print in one line the equation N - N = 0000. Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.

Sample Input 1:

6767

Sample Output 1:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174

Sample Input 2:

2222

Sample Output 2:

2222 - 2222 = 0000

题目分析:

这题解法很多,可以用字符数组的方式处理,也可以用纯数字的方式进行处理。这道题考察了几个问题显而易见:

1)数字与字符串之间的转换问题。

2)以4位数进行输出,不满4位的部分进行补0。

第二个问题如果可以处理好,那么第一个问题处理起来就很方便了。补0的最好方式是通过printf("%04d",xx);的方式进行,那么输入输出的参数类型必然是int型。然后再来处理int型的每一个位数与数组转化的问题即可。最简单的方式为%10循环取余,即可得到每个位的数字,然后sort()排序,再把数组每个位*10,循环累加即可。代码如下。

代码:

#pragma warning(disable:4996)
#include <stdio.h>
#include <algorithm>
using namespace std;

int toNum(int arr[]);//转化为一个数字
void toArray(int arr[], int num);//转化为数组

bool cmp(char a, char b)
{
	if (a > b)
		return true;
	else
		return false;
}

int main()
{
	int n;
	scanf("%d", &n);
	int small, big;//small为减数,big为被减数
	int arr[4];
	do 
	{
		toArray(arr, n);
		sort(arr, arr + 4);
		small = toNum(arr);
		sort(arr, arr + 4, cmp);
		big = toNum(arr);
		n = big - small;
		printf("%04d - %04d = %04d\n",big,small,n);//需要在不满4位时,进行补0操作
	} while (n != 0 && n != 6174);
}

int toNum(int arr[])
{
	int num=0;
	for (int i = 0; i < 4; i++)
		num = num * 10 + arr[i];
	return num;
}

void toArray(int arr[], int num)
{
	for (int i = 0; i < 4; i++)
	{
		arr[i] = num % 10;
		num /= 10;
	}
}

 

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值