Bellovin

E - Bellovin
Time Limit:3000MS     Memory Limit:131072KB     64bit IO Format:%I64d & %I64u

Description

Peter has a sequence  a_1,a_2,...,a_n  and he define a function on the sequence --  F(a_1,a_2,...,a_n)=(f_1,f_2,...,f_n) , where  f_i  is the length of the longest increasing subsequence ending with  a_i

Peter would like to find another sequence  b_1,b_2,...,b_n  in such a manner that  F(a_1,a_2,...,a_n)  equals to  F(b_1,b_2,...,b_n) . Among all the possible sequences consisting of only positive integers, Peter wants the lexicographically smallest one. 

The sequence  a_1, a_2, ..., a_n  is lexicographically smaller than sequence  b_1, b_2, ..., b_n , if there is such number  i  from  1  to  n , that  a_k = b_k  for  1 \le k < i  and  a_i < b_i .

Input

There are multiple test cases. The first line of input contains an integer  T , indicating the number of test cases. For each test case: 

The first contains an integer  n   (1 \le n \le 100000)  -- the length of the sequence. The second line contains  n  integers  a_1,a_2,...,a_n   (1 \le a_i \le 10^9) .

Output

For each test case, output  n  integers  b_1,b_2,...,b_n   (1 \le b_i \le 10^9)  denoting the lexicographically smallest sequence. 

Sample Input

3
1
10
5
5 4 3 2 1
3
1 3 5

Sample Output

1
1 1 1 1 1
1 2 3
找到每个位置可能的最长递增子序列(LIS)顺次输出就行了。


#include<stdio.h>
#include<algorithm>
#include<string.h>
#include<iostream>
using namespace std;
const int maxn = 100010;
int a[maxn],dp[maxn];
int n,t;
int main(){
	scanf("%d",&t);
	while(t--){
		int ac = 0;
		memset(a,0,sizeof(a));
		memset(dp,0,sizeof(dp)); 
		scanf("%d",&n);
		scanf("%d",&ac);
		a[1] = ac;
		int len = 1;
		dp[1] = 1;
		for(int i=2; i<=n; i++){
			scanf("%d",&ac);
			if(a[len]<ac){
				a[++len] = ac;	dp[i] = len;
			}
			else{
				int k = lower_bound(a+1,a+1+len,ac) - a;
				a[k] = ac;
				dp[i] = k;
			}
		}
		for(int i=1; i<=n; i++){
			printf("%d%c",dp[i],i == n?'\n':' ');
		}
	}
	
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值