(PAT)1002 A+B for Polynomials

This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 a~N1~ N2 a~N2~ … NK a~NK~, where K is the number of nonzero terms in the polynomial, Ni and a~Ni~ (i=1, 2, …, K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < … < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output

3 2 1.5 1 2.9 0 3.2
import java.util.Scanner;
public class Main {
    public static void main(String[] args){
        Scanner sc = new Scanner(System.in);
        String first[];
        String second[];
        String result[] = new String[20];
        int index =0 ;
        double total ;
        int firstFlag;
        int secondFlag;
        int firstlength = sc.nextInt()*2;
        first = new String[firstlength];
        for(int i=0;i<firstlength;i++){
            first[i] = sc.next();
        }
        int secondlength = sc.nextInt()*2;
        second= new String[secondlength];
        for(int i=0;i<secondlength;i++){
            second[i] = sc.next();
        }
        for(int i=0;i<10;i++){
            firstFlag = -1;
            secondFlag = -1;
            for(int j =0;j<first.length;j=j+2){
                if(i == Integer.parseInt(first[j])){
                        firstFlag = j;
                }
            }
            for(int k = 0;k<second.length;k=k+2){
                if(i==Integer.parseInt(second[k])){
                    secondFlag = k;
                }
            }
            if(firstFlag != -1 || secondFlag != -1){
                if(firstFlag!=-1 && secondFlag != -1){
                    total = Double.parseDouble(first[firstFlag+1]) + Double.parseDouble(second[secondFlag+1]);
                    if(total!=0) {
                        result[index] = String.valueOf(i);
                        index++;
                        result[index] = String.valueOf(String.format("%.1f", total));
                        index++;
                    }
                }else{
                    if(firstFlag != -1){
                        total = Double.parseDouble(first[firstFlag+1]);
                        if(total!=0) {
                            result[index] = String.valueOf(i);
                            index++;
                            result[index] = String.valueOf(String.format("%.1f", total));
                            index++;
                        }
                    }else{
                        total = Double.parseDouble(second[secondFlag+1]);
                        if(total!=0) {
                            result[index] = String.valueOf(i);
                            index++;
                            result[index] = String.valueOf(String.format("%.1f", total));
                            index++;
                        }
                    }
                }
            }
        }
        String output = String.valueOf(index/2);
        for(int i=1000;i>=0;i--){
            for(int k=0;k<result.length;k=k+2){
                if(result[k]!=null){
                    if(Integer.parseInt(result[k])==i){
                        output = output+" "+result[k]+" "+result[k+1];
                    }
                }
            }
        }
        System.out.print(output);
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值