[JAVA/PYTHON](PAT)1006 SIGN IN AND SIGN OUT (25)

49 篇文章 0 订阅
43 篇文章 0 订阅

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in’s and out’s, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time

where times are given in the format HH:MM:SS, and ID number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:

3

CS301111 15:30:28 17:00:10

SC3021234 08:00:00 11:25:25

CS301133 21:45:00 21:58:40

Sample Output:

SC3021234 CS301133

题目大意:
给定职工的上下班签到表,找到最早到的和最晚离开的人

分析:
获取所有的时间字符串,转换成秒数进行比较

Java实现

 

import java.io.BufferedReader;

import java.io.InputStreamReader;

import java.text.SimpleDateFormat;

import java.util.Date;



public class Main {

    public static void main(String[] args)throws Exception{

        BufferedReader br = new BufferedReader(new InputStreamReader(System.in));

        int earliest;

        int latest;

        SimpleDateFormat inputFormat = new SimpleDateFormat("HH:mm:ss");

        int num = Integer.valueOf(br.readLine());

        String record[][] = new String[num][3];

        for(int i=0;i<num;i++){

            record[i] = br.readLine().split(" ");

        }

        br.close();

        earliest = 0;

        latest = 0;

        for(int i=1;i<num;i++){

            Date early = inputFormat.parse(record[earliest][1]);

            Date now = inputFormat.parse(record[i][1]);

            if(now.getTime() < early.getTime()){

             earliest = i;

            }

        }

        for(int i=0;i<num;i++){

         Date late = inputFormat.parse(record[latest][2]);

            Date now = inputFormat.parse(record[i][2]);

            if(now.getTime() > late.getTime()){

             latest = i;

            }

        }

        String output;

        output = record[earliest][0]+" "+record[latest][0];

        System.out.print(output);



    }

}

注意:
1>使用java提交的时候不要把包名比如 package main包含在内,判题程序会报错。
2>不要导入没有用到的包,据说会导致错误。
3>推荐使用BufferedReader代替Scanner,因为Scanner过于耗时,一些时间限制比较紧张题目会运行超时。
4>构造SimpleDateFormat时要注意,”MM”代表月,”mm”代表分,”HH”代表24小时制,”hh”代表12小时制。
5>字符串比较大小应该使用compareTo方法。

Python实现

 

import time

if __name__ == "__main__":

    num = int(input())

    record = []

    for x in range(num):

        line = input().split(" ")

        unit = [line[0]]

        for i in line[1:]:

            timeStruct = time.strptime('2018-01-01 '+i, "%Y-%m-%d %H:%M:%S")

            timeStamp = int(time.mktime(timeStruct))

            unit.append(timeStamp)

        record.append(unit)

    early = min([ x[1] for x in record])

    late = max([x[2] for x in record])

    first = [x for x in range(num) if record[x][1] == early][0]

    last = [x for x in range(num) if record[x][2] == late][0]

    print(record[first][0], record[last][0])

注意:

1>由于UNIX的时间戳要从1970年开始,所以在将时间字符串转换成timeStruct时,如果不加年份的话,会抛出异常。

2>Python将字符串转换成时间戳,使用time.strptime(string, format)函数,先将字符串转换成timeStruct之后使用time.mktime(tuple)函数转换成时间戳。要注意的是,转换得到的是一个浮点数。

更多技术干活,有趣文章,点这里就没错

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值